Bug 804383 - vdsm: nfs metadata shows iso domain in domain list while rhevm removed iso from pool
vdsm: nfs metadata shows iso domain in domain list while rhevm removed iso fr...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: 3.1.0
Assigned To: Ayal Baron
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 10:20 EDT by Dafna Ron
Modified: 2016-02-10 12:03 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-18 08:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (5.03 MB, application/x-gzip)
2012-03-18 13:12 EDT, Dafna Ron
no flags Details

  None (edit)
Comment 1 Dafna Ron 2012-03-18 13:12:07 EDT
managed to reproduce a similar issue where metadata was not updated correctly

1) create an iso domain -> attach to nfs DC and activate it
2) import the iso domain to an iscsi DC on a different setup and while domain is attaching rename the iso domain in setup#1 (where it's attached to nfs DC). 

the iso domain metadata is updated with the name change but only has one domain in domain's list while vdsm will report the domain as attached 

please note that we cannot detach or activate the iso domain which is shown as attached to the pool and will have no choice but to destroy it.  


iso metadata: 

CLASS=Iso
DESCRIPTION=ISO_DAFNA2
IOOPTIMEOUTSEC=1
LEASERETRIES=3
LEASETIMESEC=5
LOCKPOLICY=
LOCKRENEWALINTERVALSEC=5
MASTER_VERSION=0
POOL_UUID=a5aea445-e723-423c-b112-79491470cf38
REMOTE_PATH=tiger.qa.lab.tlv.redhat.com:/volumes/tiger1/Dafna_ISO_DAFNA2_0_nfs_318162125228101
ROLE=Regular
SDUUID=08f0406f-584a-4585-b402-94e4b7ac4a38
TYPE=NFS
VERSION=0
_SHA_CKSUM=18e4f9e5ddbfa5ca03bd592574f67fc430d75681

iscsi pool
root@blond-vdsf ~]# vdsClient -s 0 getConnectedStoragePoolsList 
6474a00a-d4d7-4e90-bcdd-401d99ffb1d3

nfs pool: 

[root@orange-vdsd ~]# vdsClient -s 0 getConnectedStoragePoolsList
a5aea445-e723-423c-b112-79491470cf38


vdsClient reports that iso domain is part of pool: 

[root@blond-vdsf ~]# vdsClient -s 0 getStorageDomainsList 
322a6401-4cbe-41a7-a0c9-55a6b3d43f98
5d54547b-7e8e-4484-a896-7975e88191af
45d2387f-7052-4c28-84fc-2935b42e346d
2280d282-4f79-4294-8b31-c15bc225cf8d
856ab18e-7e18-4a2b-a880-4704771a2b29
08f0406f-584a-4585-b402-94e4b7ac4a38

[root@blond-vdsf ~]# vdsClient -s 0 getStorageDomainInfo 08f0406f-584a-4585-b402-94e4b7ac4a38
	uuid = 08f0406f-584a-4585-b402-94e4b7ac4a38
	pool = ['a5aea445-e723-423c-b112-79491470cf38']
	lver = -1
	version = 0
	role = Regular
	remotePath = tiger.qa.lab.tlv.redhat.com:/volumes/tiger1/Dafna_ISO_DAFNA2_0_nfs_318162125228101
	spm_id = -1
	type = NFS
	class = Iso
	master_ver = 0
	name = ISO_DAFNA2

attaching full logs from both servers and from rhevm
Comment 2 Dafna Ron 2012-03-18 13:12:55 EDT
Created attachment 570918 [details]
logs
Comment 3 RHEL Product and Program Management 2012-05-04 00:08:38 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 04:55:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 RHEL Product and Program Management 2012-07-10 21:55:20 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 RHEL Product and Program Management 2012-12-14 02:59:12 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.