Bug 804390 - issue promoting a system template in system engine beta4.
issue promoting a system template in system engine beta4.
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 11:30 EDT by james labocki
Modified: 2013-03-27 16:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 10:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot01.png (92.34 KB, image/png)
2012-03-18 11:31 EDT, james labocki
no flags Details
screenshot03.png (119.57 KB, image/png)
2012-03-18 11:31 EDT, james labocki
no flags Details
screenshot02.png (97.53 KB, image/png)
2012-03-18 11:33 EDT, james labocki
no flags Details
screenshot04.png (71.32 KB, image/png)
2012-03-18 11:33 EDT, james labocki
no flags Details

  None (edit)
Description james labocki 2012-03-18 11:30:41 EDT
Description of problem:
I'm having an issue promoting a system template in system engine beta4.

01.png - I successfully promoted candlepincert product to environment dev1
02.png - MySystemTemplate contains a package that is contained within the candlepincert product
03.png - The error received when attempting to promote MySystemTemplate from environment library to environment dev1
04.png I can see the package, but I can't add it to a changeset.

It appears that even though I promoted candlepincert repo to dev1 and it contains the package it is failing to promote the system template that names it as a package to dev1. Should I file a bz or am I doing something wrong?

Version-Release number of selected component (if applicable):
CloudForms System Engine Version: 0.1.303-1.el6 



Expected results:
Promotion should work
Comment 1 james labocki 2012-03-18 11:31:15 EDT
Created attachment 570907 [details]
screenshot01.png
Comment 2 james labocki 2012-03-18 11:31:46 EDT
Created attachment 570908 [details]
screenshot03.png
Comment 3 james labocki 2012-03-18 11:33:04 EDT
Created attachment 570909 [details]
screenshot02.png
Comment 4 james labocki 2012-03-18 11:33:27 EDT
Created attachment 570910 [details]
screenshot04.png
Comment 5 Jeff Weiss 2012-03-19 10:49:44 EDT
I was not able to reproduce this problem.  I did not use the same content as James though.  That makes me *highly* suspicious of this package name:

candlepin-cert-consumer-cf-se1.lab.bos.redhat.com

could be related to this:
https://bugzilla.redhat.com/show_bug.cgi?id=786963

James is on PTO for a couple weeks, I'm going to send this back to him and when I get his exact content to reproduce with, I'll reopen if necessary.

Note You need to log in before you can comment on or make changes to this bug.