Bug 804456 - CD/DVD via hotplug USB is not recognized for install
CD/DVD via hotplug USB is not recognized for install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-18 18:23 EDT by John Reiser
Modified: 2012-03-18 23:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-18 23:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2012-03-18 18:23:23 EDT
Description of problem: During install from boot.iso, at the repo selection screen ("Add additional software repositories"), then hot plugging a CD/DVD drive via USB2.0, and loading an install DVD [thus Packages/*, etc.] is not recognized.  There is no "sr1" anywhere in the log files of /tmp/*, except for /tmp/syslog which does see the new drive [and no mention of media.]


Version-Release number of selected component (if applicable):
anaconda-17.13-1.fc17.x86_64
lorax-17.10-1.fc17.x86_64


How reproducible: every time


Steps to Reproduce:
1. Boot boot.iso, proceed to repo selection screen, click "Add additional software repositories"
2. Plug in an external CD/DVD drive via USB2.0 interface, and insert an install DVD into the newly hot-plugged drive, and make sure the hardware loads the platter.
3. Choose CD/DVD for repository type, give it a name, and click OK.
  
Actual results: "No Media Found: No installation media was found. ..."
Also, there is no mention of sr1 anywhere except /tmp/syslog.  So, the platter was never inspected.


Expected results: Hot-plugged drive (and with media inserted) is recognized.


Additional info:
Comment 1 Chris Lumens 2012-03-18 22:42:07 EDT
We've never supported this behavior.  You need to plug in the device before starting anaconda.
Comment 2 John Reiser 2012-03-18 23:10:45 EDT
Please re-consider.  "Before starting anaconda" is an interesting time.  That's the time between "kernel has performed USB init" and dracut->anaconda, which is a small window, perhaps only a few seconds?  Because cold plugging does not work (the Linux kernel does not recognize general cold plugged USB devices [except keyboard and mouse {and that's only because most BIOS do "activate" those two device classes before transferring control to the boot code}]), then the practical effect of "no [anaconda] hot plug" plus "no [at boot] cold plug" is that USB devices are not supported for install.  I feel that the installer should support using an external DVD reader that is connected via USB2.0.
Comment 3 John Reiser 2012-03-18 23:30:33 EDT
OK, here's the workaround: Plug in the external DVD drive any time after kernel has initialized USB and before the installer gives an "Examining Devices" notice.  In particular, you can plug in the DVD drive (and load the platter) at the first installer graphics screen, Choose Language, where the installer will wait forever until you choose a language and activate [Next].

The first "Examining Devices" notice occurs after you choose "Baisc Devices" versus "Advanced Devices".  Later if you choose "Custom partitioning" then there is another "Examining Devices" immediately after the "Data target devices" vs "Install target devices" allocation.

Note You need to log in before you can comment on or make changes to this bug.