Bug 804513 - emacs causes broken buildroot
emacs causes broken buildroot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
17
Unspecified Unspecified
urgent Severity medium
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 02:34 EDT by Mattias Ellert
Modified: 2013-03-03 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 09:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2012-03-19 02:34:51 EDT
Description of problem:

Building a package for Fedora 17 that buildrequires emacs fails in koji.

DEBUG util.py:257:  Error: Package: 1:emacs-24.0.94-1.fc17.x86_64 (build)
DEBUG util.py:257:             Requires: libMagickCore.so.4()(64bit)
DEBUG util.py:257:  Error: Package: 1:emacs-24.0.94-1.fc17.x86_64 (build)
DEBUG util.py:257:             Requires: libMagickWand.so.4()(64bit)

The current version of emacs in F17 links to libMagickCore.so.4, but the current version of ImageMagick in the F17 buildroot (currently due to a buildroot override) provides libMagickCore.so.5

Version-Release number of selected component (if applicable):
emacs-24.0.94-1.fc17
emacs-24.0.94-2.fc17 (the changelog for this build says "Rebuild for ImageMagick update", but also this build depends on libMagickCore.so.4)

How reproducible:
Always

Steps to Reproduce:
1. Build a package that buildreqiures emacs for F17 in koji
Comment 1 Fedora Update System 2012-03-19 03:50:26 EDT
emacs-24.0.94-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/emacs-24.0.94-3.fc17
Comment 2 Mattias Ellert 2012-03-19 03:54:26 EDT
Thanks. Could you add a buildroot override too?
Comment 3 Karel Klíč 2012-03-19 04:16:20 EDT
Added.

Build: emacs-24.0.94-3.fc17
Notes: Fix buildroot for packages requiring Emacs.
Expiration: 03/23/2012
Comment 4 Fedora Update System 2012-03-20 02:04:15 EDT
Package emacs-24.0.94-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.0.94-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4206/emacs-24.0.94-3.fc17
then log in and leave karma (feedback).
Comment 5 nCdy 2012-03-23 08:36:00 EDT
Doesn't fix the problem for me:


su -c 'yum install --enablerepo=updates-testing emacs'
Password: 
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package emacs.i686 1:24.0.94-3.fc17 will be installed
--> Processing Dependency: emacs-common = 1:24.0.94-3.fc17 for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: xorg-x11-fonts-misc for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: libotf.so.0 for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: libMagickWand.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: libMagickCore.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
--> Running transaction check
---> Package emacs.i686 1:24.0.94-3.fc17 will be installed
--> Processing Dependency: libMagickWand.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: libMagickCore.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
---> Package emacs-common.i686 1:24.0.94-3.fc17 will be installed
--> Processing Dependency: liblockfile.so.1 for package: 1:emacs-common-24.0.94-3.fc17.i686
--> Processing Dependency: emacs-filesystem for package: 1:emacs-common-24.0.94-3.fc17.i686
---> Package libotf.i686 0:0.9.12-3.fc17 will be installed
---> Package xorg-x11-fonts-misc.noarch 0:7.5-5.fc17 will be installed
--> Running transaction check
---> Package emacs.i686 1:24.0.94-3.fc17 will be installed
--> Processing Dependency: libMagickWand.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
--> Processing Dependency: libMagickCore.so.5 for package: 1:emacs-24.0.94-3.fc17.i686
---> Package emacs-filesystem.i686 1:24.0.94-3.fc17 will be installed
---> Package liblockfile.i686 0:1.08-12.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: 1:emacs-24.0.94-3.fc17.i686 (updates-testing)
           Requires: libMagickCore.so.5
Error: Package: 1:emacs-24.0.94-3.fc17.i686 (updates-testing)
           Requires: libMagickWand.so.5
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 6 nCdy 2012-03-23 08:39:06 EDT
Oh not libMagickCore was updated but emacs not.
Comment 7 Tom Horsley 2012-03-25 10:38:58 EDT
Yep, I have been getting the same update errors for emacs in f17 for a while now (though in the 64 bit version for me):

[root@zooty ~]# yum -y --skip-broken update
Loaded plugins: downloadonly, fastestmirror, langpacks, presto, refresh-
              : packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.hmc.edu
 * rpmfusion-free-rawhide: mirror.us.leaseweb.net
 * rpmfusion-nonfree: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates-testing: mirror.us.leaseweb.net
 * updates: mirror.utexas.edu
 * updates-testing: mirror.utexas.edu
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package emacs.x86_64 1:24.0.94-1.fc17 will be updated
---> Package emacs.x86_64 1:24.0.94-3.fc17 will be an update
--> Processing Dependency: libMagickWand.so.5()(64bit) for package: 1:emacs-24.0.94-3.fc17.x86_64
--> Processing Dependency: libMagickCore.so.5()(64bit) for package: 1:emacs-24.0.94-3.fc17.x86_64
---> Package emacs-common.x86_64 1:24.0.94-1.fc17 will be updated
---> Package emacs-common.x86_64 1:24.0.94-3.fc17 will be an update
--> Running transaction check
---> Package emacs.x86_64 1:24.0.94-1.fc17 will be updated
--> Processing Dependency: emacs-common = 1:24.0.94-1.fc17 for package: 1:emacs-24.0.94-1.fc17.x86_64
---> Package emacs.x86_64 1:24.0.94-3.fc17 will be an update

Packages skipped because of dependency problems:
    1:emacs-24.0.94-3.fc17.x86_64 from updates-testing
    1:emacs-common-24.0.94-3.fc17.x86_64 from updates-testing
Comment 8 Karel Klíč 2012-05-21 09:50:35 EDT
The dependency problem seems to be solved now.

Note You need to log in before you can comment on or make changes to this bug.