Bug 804529 - The --ignoremeta option should also skip config validation
The --ignoremeta option should also skip config validation
Status: CLOSED NOTABUG
Product: PulpDist
Classification: Community
Component: Management CLI (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: 0.1.0
: ---
Assigned To: Nick Coghlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 03:44 EDT by Nick Coghlan
Modified: 2012-03-20 02:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 02:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2012-03-19 03:44:36 EDT
Currently, even with --ignoremeta set, the management CLI can't manipulate (e.g. delete) server directories with invalid metadata. Config validation should be skipped completely in this case.
Comment 1 Nick Coghlan 2012-03-20 02:18:50 EDT
It turns out the CLI actually behaves this way *by default*, because it doesn't retrieve the importer configurations by default - instead, it leaves them out when loading the list of repos, meaning they can't cause validation to fail.

Note You need to log in before you can comment on or make changes to this bug.