Bug 804536 - incorrect default jenkins builder size for medium gear size app
incorrect default jenkins builder size for medium gear size app
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 03:55 EDT by Meng Bo
Modified: 2012-03-19 04:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 04:28:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-03-19 03:55:17 EDT
Description of problem:
when creating medium size app with jenkins client enabled, jenkins will use small builder size by default, and will cause jenkins push build hang there.

Version-Release number of selected component (if applicable):
rhc-cartridge-jenkins-client-1.4-0.22.2-1.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.set instance profile to medium
2.create an app with medium size and jenkins enabled
#rhc app create -a testapp -t perl-5.10 -g medium --enable-jenkins
3.go to jenkins console check the default builder size for this app
  
Actual results:
the builder size for the medium size app is 'small', and will cause jenkins push build hang there since the app gear size is medium.

Expected results:
the builder size should be the same as the app gear size.

Additional info:
for the jbossas app, the jenkins builder size will be 'medium' by default.
Comment 1 Meng Bo 2012-03-19 04:28:50 EDT
close this bug since it should be by design.

Note You need to log in before you can comment on or make changes to this bug.