Bug 804554 - Fedora 17 installer doesn't recognize Broadcom BCM57780 NIC
Fedora 17 installer doesn't recognize Broadcom BCM57780 NIC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
first=3.2 tested=3.3 ethernet tg3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 04:50 EDT by Oded Arbel
Modified: 2012-07-05 14:10 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 14:10:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog from F17 install on Dell Precision 1500 (94.15 KB, text/x-log)
2012-03-22 15:00 EDT, Oded Arbel
no flags Details

  None (edit)
Description Oded Arbel 2012-03-19 04:50:58 EDT
On my Dell Precision workstation, network installations or any install that needs network access doesn't work because the onboard network interface is not recognized by the installer.

I've checked and the tg3 driver is included, but is not being initialized properly. I found this bug which seems to be related: bug #602155 broadcom.ko module missing from F-13 installer.

dmesg has this to say:
.. tg3.c:v2.122 (December 7,2011)
.. tg3 mdio bus: probed
.. tg3 0000:02:00.0: No PHY devices
.. tg3 0000:02:00.0: Problem fetching invariants of chip, aborting

while lspci lists:

02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
Comment 1 Chris Lumens 2012-03-19 10:16:19 EDT
Please attach the complete /tmp/syslog to this bug report.
Comment 2 Dave Jones 2012-03-19 11:25:16 EDT
I'm assuming the 3.1 kernel that came with F16 worked. How about the 3.2 update?
I'd like to find out how recently it broke.
Comment 3 Andy Gospodarek 2012-03-21 11:28:21 EDT
It doesn't look like the line entry for 'phy_driver_register' was removed from the kernel specfile (or from the driver) and CONFIG_BROADCOM_PHY=m is in config-generic so this does not appear to be a case where someone reverted the fix from bug 602155.
Comment 4 Oded Arbel 2012-03-22 15:00:30 EDT
Created attachment 572066 [details]
syslog from F17 install on Dell Precision 1500
Comment 5 Oded Arbel 2012-03-22 15:59:22 EDT
I wasn't sure about the F16 install as I installed it from an ISO image and didn't need any network during install.

I just tried the Fedora 16 live CD and that has networking just fine.
Comment 6 Oded Arbel 2012-03-22 17:07:25 EDT
I've just tried the F16 netinstall and it works just fine - the problem seems to be only in 17.
Comment 8 Oded Arbel 2012-03-28 04:39:55 EDT
Using the latest nightly compose (from 24/3), the live desktop comes up with the network just fine.

I don't have a nightly installer disk, so I can't check the status of that, but if someone points me to an ISO for the most up to date install disk then I'd love to try that out.
Comment 9 Dave Jones 2012-06-27 20:41:37 EDT
Is this still broken in 3.4 ?
Comment 10 Josh Boyer 2012-07-05 14:10:43 EDT
This was actually the result of dracut not including the phy module in the initramfs.  That bug was filed quite a while ago and closed out now.  Dracut version 018 or newer should include the phy modules when creating the initramfs.

Note You need to log in before you can comment on or make changes to this bug.