Bug 804562 - --ns-hostname option does not check A/AAAA record of the provided hostname.
--ns-hostname option does not check A/AAAA record of the provided hostname.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 05:26 EDT by Gowrishankar Rajaiyan
Modified: 2015-05-20 11:14 EDT (History)
3 users (show)

See Also:
Fixed In Version: ipa-2.2.0-6.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:21:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-19 05:26:04 EDT
Description of problem:
This was reported by Suvarna as part of IPA DNS Enh test day-2.

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. [root@primenova ~]# ipa dnsrecord-add lab.eng.pnq.redhat.com primenova --ns-rec=ns1.shanks.lab.eng.pnq.redhat.com.
ipa: ERROR: Nameserver 'ns1.shanks.lab.eng.pnq.redhat.com.' does not have a corresponding A/AAAA record
[root@primenova ~]# 

2. [root@primenova ~]# ipa dnsrecord-add lab.eng.pnq.redhat.com primenova --ns-hostname=ns1.shanks.lab.eng.pnq.redhat.com

  
Actual results:
  Record name: primenova
  A record: 10.65.201.100
  NS record: ns1.shanks.lab.eng.pnq.redhat.com
  SSHFP record: 1 1 E3B72BA346B90570EED94BE9334E34AA795CED23, 2 1 FD2693C1EFFC11A8D2BE57229212A04B45663791
[root@primenova ~]# 


Expected results:
ipa: ERROR: Nameserver 'ns1.shanks.lab.eng.pnq.redhat.com.' does not have a corresponding A/AAAA record

Additional info:
Comment 2 Martin Kosek 2012-03-19 05:53:41 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2550
Comment 5 Steeve Goveas 2012-04-10 08:50:47 EDT
[root@wheeljack ~]# rpm -qa | grep ipa-server-2
ipa-server-2.2.0-8.el6.x86_64
[root@wheeljack ~]#
 
[root@wheeljack ~]# ipa dnsrecord-add lab.eng.pnq.redhat.com primenova --ns-rec=ns1.shanks.lab.eng.pnq.redhat.com.
ipa: ERROR: Nameserver 'ns1.shanks.lab.eng.pnq.redhat.com.' does not have a corresponding A/AAAA record
 
[root@wheeljack ~]# ipa dnsrecord-add lab.eng.pnq.redhat.com primenova --ns-hostname=ns1.shanks.lab.eng.pnq.redhat.com
ipa: ERROR: Nameserver 'ns1.shanks.lab.eng.pnq.redhat.com' does not have a corresponding A/AAAA record
[root@wheeljack ~]#
 
Output is giving expected result. Verified in version ipa-server-2.2.0-8.el6.x86_64
Comment 7 Martin Kosek 2012-04-25 05:21:09 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 09:21:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.