Bug 804572 - Irrelevant error message when per-part modification mode is used during dnsrecord-mod operation without specifying the record.
Irrelevant error message when per-part modification mode is used during dnsre...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 05:58 EDT by Gowrishankar Rajaiyan
Modified: 2015-05-20 11:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-2.2.0-6.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-19 05:58:51 EDT
Description of problem:
This was reported by NC as part of IPA DNS Enh test day-2.

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. [root@primenova ~]# ipa dnsrecord-mod lab.eng.pnq.redhat.com test5 --a-ip-address=10.65.201.190
  

Actual results:
ipa: ERROR: no modifications to be performed

Expected results:
We should raise an relevant error message when per-part modification mode is used without specifying the record. (--a-rec= in this case)

Additional info:
Comment 2 Gowrishankar Rajaiyan 2012-03-19 07:01:11 EDT
Also, as part of negative testing the following message is displayed

[root@primenova ~]# ipa dnsrecord-add lab.eng.pnq.redhat.com bumblebee --cname-hostname=zetaprime.lab.eng.pnq.redhat.com --cname-rec=
  
Actual results:
ipa: ERROR: an internal error has occurred
Comment 3 Martin Kosek 2012-03-19 07:01:46 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2551
Comment 7 Gowrishankar Rajaiyan 2012-03-29 05:12:50 EDT
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipa-dns-181: Bug 804572 - Irrelevant error message when per-part modification mode is used during dnsrecord-mod operation without specifying the record.
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: closes https://engineering.redhat.com/trac/ipa-tests/ticket/374
:: [   LOG    ] :: verifies https://bugzilla.redhat.com/show_bug.cgi?id=804572
:: [   LOG    ] :: Executing: ipa dnsrecord-add lab.eng.pnq.redhat.com bumblebee --cname-hostname=zetaprime.lab.eng.pnq.redhat.com --cname-rec=
:: [   LOG    ] :: "ipa dnsrecord-add lab.eng.pnq.redhat.com bumblebee --cname-hostname=zetaprime.lab.eng.pnq.redhat.com --cname-rec=" failed as expected.
:: [   PASS   ] :: Error message as expected: ipa: ERROR: invalid 'cname_hostname': Raw value of a DNS record was already set by cname_rec option
:: [   LOG    ] :: Executing: ipa dnsrecord-mod lab.eng.pnq.redhat.com test5 --a-ip-address=10.65.201.190
:: [   LOG    ] :: "ipa dnsrecord-mod lab.eng.pnq.redhat.com test5 --a-ip-address=10.65.201.190" failed as expected.
:: [   PASS   ] :: Error message as expected: ipa: ERROR: 'arecord' is required
:: [   LOG    ] :: Duration: 10s
:: [   LOG    ] :: Assertions: 2 good, 0 bad
:: [   PASS   ] :: RESULT: ipa-dns-181: Bug 804572 - Irrelevant error message when per-part modification mode is used during dnsrecord-mod operation without specifying the record.
report saved as: /tmp/rhts.report.31396.txt
================ final pass/fail report =================
   Test Date: Thu Mar 29 03:36:08 EDT 2012 
   Total : [2] 
   Passed: [2] 
   Failed: [0] 
   Abort : [0]
---------------------------------------------------------


Verified: ipa-server-2.2.0-7.el6.x86_64
Comment 9 Martin Kosek 2012-04-25 05:22:33 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 errata-xmlrpc 2012-06-20 09:24:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html

Note You need to log in before you can comment on or make changes to this bug.