Bug 804614 - okular exits with an error message
okular exits with an error message
Status: CLOSED DUPLICATE of bug 658313
Product: Fedora
Classification: Fedora
Component: okular (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 08:44 EDT by David Levner
Modified: 2012-03-19 14:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 14:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PDF file that caused the okular errors on my computer (5.33 MB, application/pdf)
2012-03-19 08:44 EDT, David Levner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 261538 None None None Never

  None (edit)
Description David Levner 2012-03-19 08:44:58 EDT
Created attachment 571105 [details]
PDF file that caused the okular errors on my computer

Description of problem: When okular is closed, it says writes this to STDERR:

okular(17251)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x1f07b98 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes.

Version-Release number of selected component (if applicable):

Okular 0.13.3
KDE Development Platform 4.7.4

How reproducible:

Every time

Steps to Reproduce:

1. Start okular from a shell (my command was 'okular congee-village-menu.pdf 2>err')

2. Click the close icon (X) in the upper right corner of the okular window.
  
Actual results:

An error file (as a result of piping STDERR to a file) with error messages.

Expected results:

An empty error file.


Additional info: If I close okular by selecting 'Quit' from the 'File' menu, I get a longer error file such as this:

Plugin paths:  ("/usr/lib64/qt4/plugins", "/home/levner/.kde/lib64/", "/usr/lib64/") 
Trying to load Attica plugin:  "/usr/lib64/qt4/plugins/attica_kde.so" 
Trying to load Attica plugin:  "/home/levner/.kde/lib64//attica_kde.so" 
Trying to load Attica plugin:  "/usr/lib64//attica_kde.so" 
Using Attica with KDE support 
Plugin paths:  ("/usr/lib64/qt4/plugins", "/home/levner/.kde/lib64/", "/usr/lib64/") 
Trying to load Attica plugin:  "/usr/lib64/qt4/plugins/attica_kde.so" 
Trying to load Attica plugin:  "/home/levner/.kde/lib64//attica_kde.so" 
Trying to load Attica plugin:  "/usr/lib64//attica_kde.so" 
Using Attica with KDE support 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265) KWidgetItemDelegateEventListener::eventFilter: User of KWidgetItemDelegate should not delete widgets created by createItemWidgets! 
okular(17265)/kdeui (kdelibs) KXMLGUIClient::~KXMLGUIClient: 0x803b68 deleted without having been removed from the factory first. This will leak standalone popupmenus and could lead to crashes.

I have added the pdf file that causes the problem as an attachment. It is a menu from a Chinese restaurant in NY City that I highly recommend if you visit here!
Comment 1 Kevin Kofler 2012-03-19 14:37:48 EDT
Works for me with:
kdegraphics-4.6.5-3.fc15.i686
openjpeg-libs-1.4-12.fc15.i686

This is probably a duplicate of bug #796500, which was fixed in openjpeg-libs-1.4-12.

Do you have the latest openjpeg update? (I suspect not, given that your Okular is also out of date, 4.8.1 was pushed as a stable update for Fedora 16 yesterday.) Please retest with openjpeg-libs-1.4-12.fc16.

https://admin.fedoraproject.org/updates/FEDORA-2012-3026
Comment 2 Rex Dieter 2012-03-19 14:48:06 EDT
Likely just a dup of bug #658313 which has been there for ages, upstream bug http://bugs.kde.org/261538
Comment 3 Kevin Kofler 2012-03-19 14:55:46 EDT
Oh right, that looks more like it. The openjpeg crash would make Okular exit immediately, without printing any warnings.

*** This bug has been marked as a duplicate of bug 658313 ***

Note You need to log in before you can comment on or make changes to this bug.