Bug 804620 - Japanese : Bug tracking several pages , text needs to be translated to Japanese
Japanese : Bug tracking several pages , text needs to be translated to Japanese
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: beta6
: ---
Assigned To: Jozef Zigmund
dgao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 08:56 EDT by Shveta
Modified: 2012-05-15 18:58 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 18:58:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
English to Japanese (2.16 MB, application/msword)
2012-03-19 08:56 EDT, Shveta
no flags Details

  None (edit)
Description Shveta 2012-03-19 08:56:29 EDT
Created attachment 571117 [details]
English to Japanese

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. As in the attached doc
2. All the english text needs to be converted to Japanese
3.
  
Actual results:


Expected results:


Additional info:

rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch
Comment 1 Steve Linabery 2012-03-27 14:22:08 EDT
f1bba56430b5b7be748cc51de273a18e50476f51
0bd4d208af5f77940ca922179e1a7df238525b75
8c6a0c54fa8f7282ed5596b00afeda34a2f345e8
2a9bd91a7a5e1c1ab7f597c91eb4f3b5bb623124
6989372e32184c43104848c8d57c604f1fb96396
cc4e941644e3cfb90c5d19cc54eb141c1c67546b
from jzigmund pushed to 1.0-product
Comment 2 Steve Linabery 2012-03-28 12:21:55 EDT
b4f044b BZ 804620 added i18n for some fields in form of pools rev.
aa574bd BZ 804620 added i18n for some fields in form of pool families
4c97201 BZ 804620 Added i18n for some fields in form of deployables
Comment 4 wes hayutin 2012-03-30 14:55:58 EDT
assigning to dgao
Comment 5 dgao 2012-04-02 14:39:29 EDT
Verified except for the history screen. 

For translation in the history screen, see https://bugzilla.redhat.com/show_bug.cgi?id=809211
Comment 6 Jiri Tomasek 2012-04-04 06:49:34 EDT
The bugs described in the BZ was existent just because the activerecord translations were not present for other langs than English. The translation in forms is not needed. model attributes get translated automatically by rails, taking the strings from config/locales/activerecord/somelang.yml

Same thing can be used also on other places than forms by caling eg.

Person.human_attribute_name("first_name") # => "First name"

( http://apidock.com/rails/ActiveRecord/Base/human_attribute_name/class)

using activerecord translations clears up views a great deal and also clears translation files.
Comment 7 errata-xmlrpc 2012-05-15 18:58:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.