Bug 804679 - Need to utilize ruby distributed in base RHEL
Need to utilize ruby distributed in base RHEL
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: Distribution (Show other bugs)
1.0.0
Unspecified Unspecified
urgent Severity unspecified
: beta6
: ---
Assigned To: John Eckersberg
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 11:06 EDT by Jay Turner
Modified: 2015-01-07 19:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2012-03-19 11:06:52 EDT
Description of problem:
Currently the Ruby on Rails advisory (https://errata.devel.redhat.com/errata/stateview/12852) includes a ruby package which appears to be 2 revs down-level of the latest ruby released for 6.2.z.  This needs to be resolved before we can GA CloudForms.  In talking to Hugh, seems there was one patch the CF guys were looking to see included in ruby, but I am not sure if that patch is actually included in the latest z-stream release.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Eckersberg 2012-03-26 10:47:16 EDT
https://errata.devel.redhat.com/errata/stateview/12853 contains the required fix for CloudForms, so once that is pushed live we will untag our ruby build and consume that one instead.
Comment 2 Hugh Brock 2012-03-27 16:46:40 EDT
12853 is live and we have untagged ruby 1.8.7 from ce-rhel6.
Comment 4 wes hayutin 2012-04-17 14:47:44 EDT
[root@qeblade30 conf]# repoquery -q --qf="%{name} %{repoid} %{location}" ruby
ruby rhel6-updates http://download.devel.redhat.com/brewroot/packages/ruby/1.8.7.352/7.el6_2/x86_64/ruby-1.8.7.352-7.el6_2.x86_64.rpm


[root@qeblade30 conf]# rpm -q ruby
ruby-1.8.7.352-7.el6_2.x86_64


ruby.x86_64 : An interpreter of object-oriented scripting language
Repo        : beaker-Server
Matched from:


[root@qeblade30 conf]# cat /etc/yum.repos.d/beaker-Server.repo 
[beaker-Server]
name=beaker-Server
baseurl=http://lab-02.rhts.eng.bos.redhat.com/net/bigpapi.bos.redhat.com/vol/engarchive2/redhat/released/RHEL-6/6.2/Server/x86_64/os/Server
enabled=1
gpgcheck=0
skip_if_unavailable=1
Comment 6 errata-xmlrpc 2012-05-15 16:56:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0584.html

Note You need to log in before you can comment on or make changes to this bug.