Bug 804775 - [multi-gpu] No output on initial onboard graphics display
[multi-gpu] No output on initial onboard graphics display
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 14:35 EDT by Jiri Koten
Modified: 2017-12-06 05:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 25943 None None None Never

  None (edit)
Description Jiri Koten 2012-03-19 14:35:27 EDT
Description of problem:
I have two graphics cards, onboard Intel and dedicated NVidia. If I set onboard graphics as the first display (in BIOS), I see no output from plymouth. The output is displayed on NVidia graphics display. Both grub menu and X session are displayed on onboard graphics display. 

The output is displayed if I blacklist the nouveau driver (boot with rdblacklist=nouveau).         

Version-Release number of selected component (if applicable):
plymouth-0.8.3-24.el6

How reproducible:
100%

Steps to Reproduce:
1.Set the onboard graphics as the first display. (in BIOS)
2.Boot up
  
Actual results:
No output

Expected results:
plymouth output displayed on the first display

Additional info:
Comment 1 Jiri Koten 2012-04-17 10:27:52 EDT
The similar problem happens on Laptops with switch-able graphics, e.g. NVidia Optimus. On testing machine Thinkpad T520 (42435GG), there is option in BIOS where you can switch between discrete and integrated graphics or use both (Optimus). 

When I use the Optimus mode I don't see a graphical boot on the display. I see pre-boot msg and then X session. I'm able to switch to detailed, text mode.
When I boot with rdblacklist=nouveau, the graphical boot is displayed.

hw:
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [Quadro NVS 4200M] [10de:1057] (rev a1)
Comment 3 Suzanne Yeghiayan 2012-05-14 15:03:03 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Matthias Clasen 2013-01-03 14:47:51 EST
moving to 6.5
Comment 5 RHEL Product and Program Management 2013-10-13 20:45:39 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Jan Kurik 2017-12-06 05:22:58 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.