Bug 804781 - ovirt-engine-core : Cannot create multiple snapshots on VM
ovirt-engine-core : Cannot create multiple snapshots on VM
Status: CLOSED DUPLICATE of bug 801289
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: lpeer
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 14:45 EDT by Oded Ramraz
Modified: 2012-03-20 07:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 07:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (234.93 KB, application/zip)
2012-03-19 15:02 EDT, Oded Ramraz
no flags Details

  None (edit)
Description Oded Ramraz 2012-03-19 14:45:15 EDT
Description of problem:

When i try to create multiple snapshots on my VM I get an error message : 
"Cannot create Snapshot. The VM is performing an operation on a Snapshot. Please wait for the operation to finish, and try again."


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

2012-03-19 20:18:18,211 - MainThread - vms - DEBUG - CREATE request content is --  url:http://localhost:8080/api/vms/564b9d56-6a06-40c9-9ad4-19ba4bfdd49e/snapshots body:<snapshot><description>snapshot2</description></snapshot> 
2012-03-19 20:18:18,368 - MainThread - vms - DEBUG - Response body for CREATE request is: <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot create Snapshot. The VM is performing an operation on a Snapshot. Please wait for the operation to finish, and try again.]</detail>
</fault>
Comment 1 Oded Ramraz 2012-03-19 15:02:33 EDT
Created attachment 571212 [details]
engine.log
Comment 2 Mike Kolesnik 2012-03-20 07:52:18 EDT
The snapshot behavior changed so that when snapshot is taken the VM is not locked, but only the specific snapshot gets locked (this is needed to allow live snapshots).

The problem is that API doesn't expose the snapshot status so there is no way to query on the status of the snapshot. This will be fixed in bug 801289.

*** This bug has been marked as a duplicate of bug 801289 ***

Note You need to log in before you can comment on or make changes to this bug.