Bug 804798 - katello CLI fails to work properly in conjunction with cfse deployment
katello CLI fails to work properly in conjunction with cfse deployment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
Unspecified Unspecified
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Garik Khachikyan
: Triaged
: 803494 (view as bug list)
Depends On:
Blocks: 703617
  Show dependency treegraph
 
Reported: 2012-03-19 15:42 EDT by Corey Welton
Modified: 2015-01-04 16:59 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2012-03-19 15:42:49 EDT
Description of problem:
If a user installs katello with --deploy=cfse, the cli doesn't work properly.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform a katello install; deploy via `katello-configure --deploy=cfse`
2.  katello -u admin -p admin system report --org ACME_Corporation --format pdf - view results
3. Perform a katello install; deploy via `katello-configure`  (w/o params, using standard "katello" deployment)
4.  katello -u admin -p admin system report --org ACME_Corporation --format pdf - view results
  
Actual results:

* After step #2: 
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
No report generated

* After step #4:
Report generated.

Expected results:
Report generated either way.

Additional info:
This seems to affect a lot, if not all, of cli functionality.
For example, running this command on a system with no repos synced -- and such should at least return an error:

katello -u admin -p admin package list --org ACME_Corporation --repo zoo-x86_64 --product zoo-18

the end result is the same

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
Comment 1 Corey Welton 2012-03-19 16:35:07 EDT
apparently /etc/katello/client.conf is not getting updated appropriately per deploy parameter
Comment 3 Mike McCune 2012-03-19 18:54:06 EDT
*** Bug 803494 has been marked as a duplicate of this bug. ***
Comment 5 Jordan OMara 2012-03-20 10:49:34 EDT
Cannot reproduce with the following rpms:

katello-common-0.1.305-1.el6.noarch
katello-configure-0.1.106-1.el6.noarch
katello-cli-0.1.105-1.el6.noarch
katello-0.1.305-1.el6.noarch
katello-all-0.1.305-1.el6.noarch
katello-cli-common-0.1.105-1.el6.noarch

katello-configure --deployment=cfse

...

[root@maccy ~]# katello -u admin -p admin ping
          candlepin        ok       136ms               
          katello_jobs     ok       195ms               

[root@maccy ~]# katello -u admin -p admin shell
cfse>
Comment 6 Jordan OMara 2012-03-20 17:17:38 EDT
Believe it is fixed in .305 & configure .106
Comment 7 Garik Khachikyan 2012-03-21 07:10:49 EDT
# VERIFIED

checked on katello|cfse

for cfse the deployment=cfse is specified. For katello - nothing.

Both cases cli works perfectly fine.

checked against:
---
mod_wsgi-3.3-3.pulp.el6.x86_64
katello-common-0.2.15-1.git.0.16f633a.el6.noarch
pulp-selinux-server-1.0.0-6.el6.noarch
katello-repos-testing-0.2.1-1.el6.noarch
qpid-cpp-server-ssl-0.12-6.el6.x86_64
candlepin-0.5.26-1.el6.noarch
candlepin-tomcat6-0.5.26-1.el6.noarch
katello-certs-tools-1.1.3-1.el6.noarch
qpid-cpp-server-0.12-6.el6.x86_64
katello-glue-foreman-0.2.15-1.git.0.16f633a.el6.noarch
katello-0.2.15-1.git.0.16f633a.el6.noarch
qpid-cpp-client-ssl-0.12-6.el6.x86_64
katello-qpid-client-key-pair-1.0-1.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
pulp-common-1.0.0-6.el6.noarch
katello-cli-0.2.15-1.git.0.821013f.el6.noarch
qpid-cpp-client-0.12-6.el6.x86_64
katello-glue-pulp-0.2.15-1.git.0.16f633a.el6.noarch
katello-selinux-0.2.3-1.git.57.6c5edb8.el6.noarch
katello-all-0.2.15-1.git.0.16f633a.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
python-qpid-0.12-1.el6.noarch
katello-cli-common-0.2.15-1.git.0.821013f.el6.noarch
katello-glue-candlepin-0.2.15-1.git.0.16f633a.el6.noarch
pulp-1.0.0-6.el6.noarch
katello-repos-0.2.1-1.el6.noarch
katello-configure-0.2.15-1.git.4.94aa90a.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
---
Comment 9 Mike McCune 2013-08-16 14:09:08 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.