Bug 804809 - backport skb_frag api
backport skb_frag api
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
All Unspecified
high Severity high
: rc
: ---
Assigned To: Neil Horman
Network QE
:
Depends On: 809207
Blocks: 796821
  Show dependency treegraph
 
Reported: 2012-03-19 16:04 EDT by Neil Horman
Modified: 2013-01-07 23:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:50:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Horman 2012-03-19 16:04:29 EDT
Description of problem:
upstream drivers have shifted to using the skb_frag_* api, embodied in the upstream commit 
9e903e085262ffbf1fc44a17ac06058aca03524a
This bug is to track the backport of this API.  The commit affects most network drivers.  This bug is to track the common api bits.  Individual drivers are expected to backport call sites relevant to those drivers.
Comment 1 Weibing Zhang 2012-03-20 23:33:15 EDT
Will run NIC driver tests as regression test.
Set qa_ack+.
Comment 2 RHEL Product and Program Management 2012-03-30 10:21:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Weibing Zhang 2012-09-25 03:25:14 EDT
Run NIC driver tests for all drivers in key hardware list.
https://wiki.test.redhat.com/RhelQe/Rhel59/HardwarePriority#preview

Reivew the code and make sure the patch is included in kernel-2.6.18-339.el5.

Set SanityOnly.
Comment 7 errata-xmlrpc 2013-01-07 23:50:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0006.html

Note You need to log in before you can comment on or make changes to this bug.