Bug 804822 - boost-openmpi library links to old (now missing) version of openmpi libraries
boost-openmpi library links to old (now missing) version of openmpi libraries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: boost (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Petr Machata
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 16:31 EDT by Russell Taylor
Modified: 2015-05-04 21:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 09:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Taylor 2012-03-19 16:31:11 EDT
Description of problem:

The version of OpenMPI was upgraded with the release of RHEL6.2, which led to a change in the shared library version numbers (libmpi.so.0 -> libmpi.so.1, libmpi_cxx.so.0 -> 1, libopen-pal.so.0 -> 2, libopen-rte.so.0 -> 2).

The boost-openmpi package has not been upgraded or rebuilt and links directly to the old libraries.

Version-Release number of selected component (if applicable):

Version     : 1.41.0
Release     : 11.el6_1.2

Steps to Reproduce:
1. Install the boost-openmpi package (be sure to uninstall openmpi first if it's already there).
2. ldd /usr/lib64/openmpi/lib/libboost_mpi.so and see the 'not found' statements next to the affected libraries
3. ls /usr/lib64/openmpi/lib and note that the mpi libraries mentioned above are there but with different version numbers
  
Actual results:

Programs using boost::mpi fail on startup because they can't locate shared libraries.

Expected results:

Programs using boost::mpi work!

Additional info:

This probably also applies to the boost-openmpi-python package.
Comment 3 Petr Machata 2012-03-19 17:54:57 EDT
Right, we need to rebuild boost to fix this.
Re boost-openmpi-python, there's a related bug 801534.
Comment 4 Russell Taylor 2012-03-21 11:29:58 EDT
Since I created this ticket I've noticed the compat-openmpi package. This contains libraries named as the 'old' versions. However, I still find that I need to link to the 'new' ones as well or I get linker errors.
Comment 5 Petr Machata 2012-03-21 12:53:36 EDT
Ah, of course, it makes sense that there would be a compat library.  It didn't occur to me to check for that.

You shouldn't need to link to both the new and the old library, that's very suspicious and if it works, it is a happy coincidence.  Make sure that you are compiling against the compat library headers.  Compilation against the new headers would presumably lead to you having to link with the new libraries as well.
Comment 6 Russell Taylor 2012-03-23 16:42:37 EDT
The last comment led me to look for a compat-openmpi-devel package, which does indeed exist and contains the headers and mpi compiler wrappers so that things only link to the old libraries.

So if there's anything to fix, it's the dependencies in the boost-openmpi packages: 
 - boost-openmpi pulls in openmpi as well as compat-openmpi - it's not clear why.
 - boost-openmpi-devel does not pull in compat-openmpi-devel (or openmpi-devel) for that matter.
Comment 7 RHEL Product and Program Management 2012-07-10 04:10:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 19:08:01 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 RHEL Product and Program Management 2012-09-07 01:29:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2013-10-13 20:45:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 12 Petr Machata 2013-10-18 09:10:57 EDT
I believe the following erratum fixed this problem (since a mere rebuild was all that was necessary):

  https://rhn.redhat.com/errata/RHBA-2013-0692.html

That was for 6.4.Z, which means the updated package should be generally available in 6.5.

Note You need to log in before you can comment on or make changes to this bug.