Bug 804845 - Domain name validation JS breaks form submission box
Domain name validation JS breaks form submission box
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 18:43 EDT by Clayton Coleman
Modified: 2014-01-12 20:42 EST (History)
4 users (show)

See Also:
Fixed In Version: rhc-site-0.89.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 14:35:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-03-19 18:43:59 EDT
1) Log into new console
2) Enter a domain name like 'abc.'
3) A validation message shows up (using incorrect formatting)
4) Click save

Actual: loading icon spins forever, form is not submitted
Expected: Either form submission is blocked by JS, or succeeds, but not both.

High priority for sprint 8, not sprint 7 exit (can't remove old console with a bug like this).
Comment 1 Xiaoli Tian 2012-03-19 22:01:06 EDT
I think this may be a duplicate of this bug : https://bugzilla.redhat.com/show_bug.cgi?id=803679,

Not only here but also other places.
Comment 2 Fotios Lindiakos 2012-03-20 17:19:55 EDT
Finally found the correct place to stop the spinner on form submission, now it
verifies that there are no errors before starting.

Both bugs had similar fixes although were caused by different issues with the form validation code.
Comment 3 Yujie Zhang 2012-03-21 04:13:53 EDT
Verify this bug on devenv_1668, it has been fixed now.

Note You need to log in before you can comment on or make changes to this bug.