Bug 804860 - SELinux is preventing /usr/lib/cups/cgi-bin/admin.cgi from 'connectto' accesses on the unix_stream_socket /run/cups/cups.sock.
SELinux is preventing /usr/lib/cups/cgi-bin/admin.cgi from 'connectto' access...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bdcadbb0215a6a32a186cc567de...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 21:00 EDT by forum-dante
Modified: 2012-03-21 16:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 16:22:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description forum-dante 2012-03-19 21:00:27 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.10-3.fc16.x86_64
reason:         SELinux is preventing /usr/lib/cups/cgi-bin/admin.cgi from 'connectto' accesses on the unix_stream_socket /run/cups/cups.sock.
time:           Di 20 Mär 2012 01:46:33 CET

description:
:SELinux is preventing /usr/lib/cups/cgi-bin/admin.cgi from 'connectto' accesses on the unix_stream_socket /run/cups/cups.sock.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that admin.cgi should be allowed connectto access on the cups.sock unix_stream_socket by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep admin.cgi /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
:Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
:                              023
:Target Objects                /run/cups/cups.sock [ unix_stream_socket ]
:Source                        admin.cgi
:Source Path                   /usr/lib/cups/cgi-bin/admin.cgi
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           cups-1.5.2-1.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.10-3.fc16.x86_64 #1 SMP Thu
:                              Mar 15 19:39:46 UTC 2012 x86_64 x86_64
:Alert Count                   31
:First Seen                    Mo 19 Mär 2012 23:22:52 CET
:Last Seen                     Di 20 Mär 2012 01:45:00 CET
:Local ID                      06da19ec-7882-494f-87c6-4e7ec1019b1a
:
:Raw Audit Messages
:type=AVC msg=audit(1332204300.227:290): avc:  denied  { connectto } for  pid=32588 comm="admin.cgi" path="/run/cups/cups.sock" scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket
:
:
:type=SYSCALL msg=audit(1332204300.227:290): arch=x86_64 syscall=connect success=yes exit=0 a0=4 a1=7f2d6d9f1668 a2=1a a3=7fff5d1848d0 items=0 ppid=1474 pid=32588 auid=4294967295 uid=4 gid=7 euid=4 suid=4 fsuid=4 egid=7 sgid=7 fsgid=7 tty=(none) ses=4294967295 comm=admin.cgi exe=/usr/lib/cups/cgi-bin/admin.cgi subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: admin.cgi,cupsd_t,unconfined_t,unix_stream_socket,connectto
:
:audit2allow
:
:#============= cupsd_t ==============
:allow cupsd_t unconfined_t:unix_stream_socket connectto;
:
:audit2allow -R
:
:#============= cupsd_t ==============
:allow cupsd_t unconfined_t:unix_stream_socket connectto;
:
Comment 1 forum-dante 2012-03-19 21:13:11 EDT
Unable to login in the cups server over the Webpage. Admin login does not exepted. Everytime comes up an new login Window.
Comment 2 Daniel Walsh 2012-03-20 12:08:03 EDT
This looks like you have a process running as unconfined_t that the cups server is trying to connect to.

Are you running a service as unconfined_t like httpd?
Comment 3 forum-dante 2012-03-21 13:59:51 EDT
Sorry for my late answer, I don't know what happen. That was an fresh Install without any additional Software. Only I have installed "Fedora Utils to get some extra Software. Possible that was here the Problem. Now, I have do a fresh Install again with updates. Also have installed "Fedora Utils" but it  seems that the Problem solved. Now I'm able to login in cups.

I follow next time what I do with configuration and maybe I can reproduce the bug.
Comment 4 Daniel Walsh 2012-03-21 16:22:11 EDT
Ok if it happens again reopen.

Note You need to log in before you can comment on or make changes to this bug.