Bug 804900 - Error Downloading Packages: ruby-augeas-0.3.0-1.el6.x86_64 during "yum install aeolus-all"
Error Downloading Packages: ruby-augeas-0.3.0-1.el6.x86_64 during "yum inst...
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-all (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Linabery
wes hayutin
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 01:44 EDT by Rehana
Modified: 2012-08-30 13:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 13:14:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
install (113.84 KB, text/plain)
2012-03-21 10:18 EDT, wes hayutin
no flags Details

  None (edit)
Description Rehana 2012-03-20 01:44:03 EDT
Description of problem:

Unable to install aeolus due to package download error

How reproducible:

Repo used:

*********
cat aeolus-brew-nightly.repo 
# Place this file in your /etc/yum.repos.d/ directory
[aeolus-brew-nightly]
name=Aeolus RPMs and Dependencies,in brew
baseurl=http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/2012-03-16.1/el6-ce/x86_64/
#baseurl=http://download.devel.redhat.com/rel-eng/CloudForms/CloudEngine/1.0/latest/x86_64/
#baseurl=http://download.lab.bos.redhat.com/rel-eng/CloudForms/CloudEngine/1.0/latest/el6/x86_64/
enabled=1
#skip_if_unavailable=1
gpgcheck=0
******************
  
Actual results:
Installation failed with the below error:

**error***

Total size: 77 M
Total download size: 19 k
Installed size: 252 M
Is this ok [y/N]: y
Downloading Packages:
ruby-augeas-0.3.0-1.el6.x86_64.rpm               |  19 kB     00:00     
http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/2012-03-16.1/el6-ce/x86_64/ruby-augeas-0.3.0-1.el6.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=aeolus-brew-nightly clean metadata
Trying other mirror.

Error Downloading Packages:
  ruby-augeas-0.3.0-1.el6.x86_64: failure: ruby-augeas-0.3.0-1.el6.x86_64.rpm from aeolus-brew-nightly: [Errno 256] No more mirrors to try.
Comment 1 wes hayutin 2012-03-20 14:38:54 EDT
[root@qeblade30 ~]# rpm -qa | grep ruby-augeas
ruby-augeas-0.3.0-1.el6.x86_64
[root@qeblade30 ~]# rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-doc-0.8.2-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
aeolus-conductor-daemons-0.8.2-1.el6.noarch
aeolus-all-0.8.2-1.el6.noarch
aeolus-conductor-0.8.2-1.el6.noarch
aeolus-configure-2.5.1-1.el6.noarch
[root@qeblade30 ~]# 


must have been fixed since opening
Comment 2 Shveta 2012-03-21 01:16:05 EDT
Still getting the issue on a fresh install ..

http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/latest/el6-ce/


ruby-augeas-0.3.0-1.el6.x86_64.rpm                       |  19 kB     00:00     
http://download.lab.bos.redhat.com/rel-eng/CloudForms/1.0/beta5/el6-ce/x86_64/ruby-augeas-0.3.0-1.el6.x86_64.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=aeolus-brew-nightly clean metadata
Trying other mirror.


Error Downloading Packages:
  ruby-augeas-0.3.0-1.el6.x86_64: failure: ruby-augeas-0.3.0-1.el6.x86_64.rpm from aeolus-brew-nightly: [Errno 256] No more mirrors to try.

Reopening...
Comment 3 Jay Greguske 2012-03-21 09:05:29 EDT
Please clean your repodata with "yum clean all" and try again.
Comment 4 wes hayutin 2012-03-21 10:18:07 EDT
Created attachment 571722 [details]
install

baseurl=http://download.lab.bos.redhat.com/brewroot/repos/ce-rhel-6-build/latest/$basearch/


works with the above repo.. attaching txt
Comment 5 Jay Greguske 2012-03-21 11:07:57 EDT
To elaborate, we've identified the problem, but not yet the cause. That investigation is ongoing. For some reason, the beta-signed RPMs under brewroot/packages are being copied over the gold-signed RPMs for this package. We suspect a script somewhere is going awry, but we're conducting an internal investigation to make sure no other packages are being hit by this.

The problem gets exposed in puddles because the RPMs there are hardlinks to the RPMs under Brew. What happens is the puddle gets generated with the correct RPMs, and the repodata is generated from that. At some point, the gold RPMs get overwritten with the beta ones, which leads to the checksum errors because the repodata in the puddle is referencing the gold RPMs.
Comment 6 Shveta 2012-03-22 01:03:27 EDT
Working now 

rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-14.el6.noarch
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch
aeolus-all-0.8.0-43.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.