Bug 804949 - Virtualization - Removing host machine from Spacewalk leaves guests in invalid state
Virtualization - Removing host machine from Spacewalk leaves guests in invali...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
550
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On:
Blocks: 819032
  Show dependency treegraph
 
Reported: 2012-03-20 05:41 EDT by Martin Minar
Modified: 2016-07-03 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:58:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PostgreSQL log output on ISE (3.15 KB, text/plain)
2012-03-20 05:41 EDT, Martin Minar
no flags Details

  None (edit)
Description Martin Minar 2012-03-20 05:41:50 EDT
Created attachment 571327 [details]
PostgreSQL log output on ISE

Description of problem:
When machine hosting two registered guest is removed from registered systems the guests remain as "Guests Consuming Regular Entitlements" (even thou they should switch to flex guest entitlement), they don't consume any entitlement at all and also when "Convert to Flex Guest Entitlement" is used in WebUI, there is ISE.

Version-Release number of selected component (if applicable):
Spacewalk 1.7 PostgreSQL

How reproducible:
1of1

Steps to Reproduce:
1. Have virtual guest registered to Spacewalk - guest should consume flex guest entitlement.
2. Have host machine that is running this guest also registered to same Spacewalk and give it Virtualization entitlement - guest should stop consume any entitlements.
3. Delete host machine from list of registered systems.
  
Actual results:
Guest is marked as "Consuming Regular Entitlement", but he does not consume anything (check Overview > Subscription Management). Also when Convert To Flex Guest Entitlement button is used in Overview > Subscription Management > Virtualization Entitlement > Guest Consuming Regular it ends up with ISE - postgresql log attached.

Expected results:
When host is deleted, guests are changed back to flex guest entitlement.

Additional info:
Comment 1 Jan Pazdziora 2012-04-03 10:44:29 EDT
Fixed in Spacewalk master, 2c363146675e88fb5517f39aacc04efb842058bb and 1b5ad3b08936594c0e4ea75b1ed045e40f03a663.
Comment 7 Clifford Perry 2013-10-01 17:58:41 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.