Bug 805006 - [RFE] add group priorities
[RFE] add group priorities
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.8
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Nick Coghlan
GroupModel
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 08:29 EDT by Vladimir Benes
Modified: 2013-04-15 04:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-15 04:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2012-03-20 08:29:19 EDT
Description of problem:
I am in 3 groups, general, desktop and wireless but I am still receiving machines from wireless lab. Those machine are really network restricted so not good for my general tests. I need to execute tests in wireless lab from time to time too.


Version-Release number of selected component (if applicable):
0.8


Expected results:
I would like to set highest priority to desktop group (to use our machines), then general if our pool is fully occupied and then wireless. 

Additional info:
Comment 1 Marian Csontos 2012-03-20 09:22:23 EDT
Specifying <group op="!=" value="GROUP_TO_EXCLUDE"/> works for me to avoid using machines with special-HW from one group to be used for tasks which:

- could run on anything and/or
- belong to other group

This often results in longer wait time for me, but is believed to increase the universe happiness sum.
Comment 2 Nick Coghlan 2012-10-17 00:36:59 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 3 Nick Coghlan 2013-04-15 04:42:23 EDT
For Beaker 1.1, we should be implementing the concept of "System Pools", which will allow this behaviour to be controlled through a different mechanism.

Note You need to log in before you can comment on or make changes to this bug.