Bug 805087 - Fatal errors in UI are not user-friendly displayed
Fatal errors in UI are not user-friendly displayed
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 10:49 EDT by Lukas Zapletal
Modified: 2014-09-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Zapletal 2012-03-20 10:49:56 EDT
Steps to Reproduce:
1. Create a CFSE instance
2. login
3. service postgresql stop
4. click on something in the UI

katello-0.2.14-1.el6.noarch
katello-cli-0.2.13-1.el6.noarch
katello-agent-1.0.2-1.el6.noarch
pulp-1.0.0-2.el6.noarch
candlepin-0.5.26-1.el6.noarch
subscription-manager-0.96.17-1.el6.x86_64
python-rhsm-0.96.15-1.el6.noarch
yum-3.2.29-22.el6.noarch

  
Actual results:

Plain error page:

PGError

invalid encoding name: UTF8
Rails.root: /usr/share/katello


Expected results:

User-friendly, templated page apologizing for inconvinience and displaying "Database is down" error.

Additional info:

This should be generic (any fatal error should render like this one)
Comment 2 Mike McCune 2012-08-15 18:28:51 EDT
I've wanted a 'heartbeat' that will throw up a decent error page if services are down:

* candlepin
* pulp
* postgres
* mongo
etc..
Comment 3 Mike McCune 2014-03-18 13:39:07 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.