Bug 805145 - thunderbird seems to be locking up hard on me.
thunderbird seems to be locking up hard on me.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 11:35 EDT by Daniel Walsh
Modified: 2012-04-05 04:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 04:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
thunderbird-bin stack trace (7.80 KB, text/plain)
2012-03-28 14:32 EDT, Dimitri Papadopoulos
no flags Details
thunderbird freeze stack trace (146.59 KB, text/plain)
2012-03-28 15:59 EDT, Dimitri Papadopoulos
no flags Details

  None (edit)
Description Daniel Walsh 2012-03-20 11:35:18 EDT
Description of problem:

Frequently Thunderbird locks up and needs to be killed and restarted in F17.

thunderbird-lightning-1.3-3.fc17.x86_64
thunderbird-11.0-5.fc17.x86_64

Killing it via X Ends up with the 

Mozilla Thunderbird is not responding.  And I have to Force Quit.

#0  __lll_lock_wait ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:136
#1  0x00000032aa409c8c in _L_lock_1024 () from /lib64/libpthread.so.0
#2  0x00000032aa409c35 in __pthread_mutex_lock (mutex=0x7f3abc05b0e8)
    at pthread_mutex_lock.c:105
#3  0x00000032b9023529 in PR_Lock () from /lib64/libnspr4.so
#4  0x00000032b9023b1b in PR_EnterMonitor () from /lib64/libnspr4.so
#5  0x00000032b90142e0 in PR_CEnterMonitor () from /lib64/libnspr4.so
#6  0x00007f3abae534dd in ?? () from /usr/lib64/thunderbird/libxul.so
#7  0x00007f3abae2f2cb in ?? () from /usr/lib64/thunderbird/libxul.so
#8  0x00007f3abae7022a in ?? () from /usr/lib64/thunderbird/libxul.so
#9  0x00007f3abae70a91 in ?? () from /usr/lib64/thunderbird/libxul.so
#10 0x00007f3abae71fb5 in ?? () from /usr/lib64/thunderbird/libxul.so
#11 0x00007f3abad53d62 in ?? () from /usr/lib64/thunderbird/libxul.so
#12 0x00007f3abad7e3cd in ?? () from /usr/lib64/thunderbird/libxul.so
#13 0x00007f3abad92162 in ?? () from /usr/lib64/thunderbird/libxul.so
#14 0x00007f3abad83a98 in ?? () from /usr/lib64/thunderbird/libxul.so
#15 0x00007f3abafe05b5 in NS_InvokeByIndex_P ()
   from /usr/lib64/thunderbird/libxul.so
#16 0x00007f3abaace09f in ?? () from /usr/lib64/thunderbird/libxul.so
#17 0x00007f3abaad2c1e in ?? () from /usr/lib64/thunderbird/libxul.so
#18 0x00007f3abb142c6a in ?? () from /usr/lib64/thunderbird/libxul.so
#19 0x00007f3abb1329d1 in ?? () from /usr/lib64/thunderbird/libxul.so
---Type <return> to continue, or q <return> to quit---
#20 0x00007f3abb142d41 in ?? () from /usr/lib64/thunderbird/libxul.so
#21 0x00007f3abb1434ee in ?? () from /usr/lib64/thunderbird/libxul.so
#22 0x00007f3abb0bb0c4 in JS_CallFunctionValue ()
   from /usr/lib64/thunderbird/libxul.so
#23 0x00007f3aba8985cf in ?? () from /usr/lib64/thunderbird/libxul.so
#24 0x00007f3aba8e1548 in ?? () from /usr/lib64/thunderbird/libxul.so
#25 0x00007f3aba7a5389 in ?? () from /usr/lib64/thunderbird/libxul.so
#26 0x00007f3aba7b926d in ?? () from /usr/lib64/thunderbird/libxul.so
#27 0x00007f3aba7b9649 in ?? () from /usr/lib64/thunderbird/libxul.so
#28 0x00007f3aba7b9d9d in ?? () from /usr/lib64/thunderbird/libxul.so
#29 0x00007f3aba7ba08f in ?? () from /usr/lib64/thunderbird/libxul.so
#30 0x00007f3aba74420d in ?? () from /usr/lib64/thunderbird/libxul.so
#31 0x00007f3aba70f1a1 in ?? () from /usr/lib64/thunderbird/libxul.so
#32 0x00007f3aba7b900e in ?? () from /usr/lib64/thunderbird/libxul.so
#33 0x00007f3aba7100f4 in ?? () from /usr/lib64/thunderbird/libxul.so
#34 0x00007f3aba9fb418 in ?? () from /usr/lib64/thunderbird/libxul.so
#35 0x00007f3aba9fbedf in ?? () from /usr/lib64/thunderbird/libxul.so
#36 0x00007f3abafe05b5 in NS_InvokeByIndex_P ()
   from /usr/lib64/thunderbird/libxul.so
#37 0x00007f3abaace09f in ?? () from /usr/lib64/thunderbird/libxul.so
#38 0x00007f3abaad2c1e in ?? () from /usr/lib64/thunderbird/libxul.so
#39 0x00007f3abb142c6a in ?? () from /usr/lib64/thunderbird/libxul.so
#40 0x00007f3abb1329d1 in ?? () from /usr/lib64/thunderbird/libxul.so
---Type <return> to continue, or q <return> to quit---
#41 0x00007f3abb142d41 in ?? () from /usr/lib64/thunderbird/libxul.so
#42 0x00007f3abb1434ee in ?? () from /usr/lib64/thunderbird/libxul.so
#43 0x00007f3abb0bb0c4 in JS_CallFunctionValue ()
   from /usr/lib64/thunderbird/libxul.so
#44 0x00007f3abaac8cab in ?? () from /usr/lib64/thunderbird/libxul.so
#45 0x00007f3abaac429b in ?? () from /usr/lib64/thunderbird/libxul.so
#46 0x00007f3abafe1193 in ?? () from /usr/lib64/thunderbird/libxul.so
#47 0x00007f3abafe068f in ?? () from /usr/lib64/thunderbird/libxul.so
#48 0x00007f3a9f811ca0 in ?? ()
#49 0x00007f3aa3856c38 in ?? ()
#50 0x00007f3aa386cc40 in ?? ()
#51 0x0000000000000040 in ?? ()
#52 0x000000004f68a2b7 in ?? ()
#53 0x00007f3abbe10bb8 in ?? () from /usr/lib64/thunderbird/libxul.so
#54 0xfffbff3a9d4e8a00 in ?? ()
#55 0x76456d6574496e4f in ?? ()
#56 0x0000000000000000 in ?? ()
Comment 2 Jan Horak 2012-03-23 09:39:09 EDT
I'm experiencing same issue with lightning installed. As temporary workaround I suggest to remove thunderbird-lightning package.
Comment 3 James Cape 2012-03-27 09:59:07 EDT
Possible explanation (this also has been biting at least one of my users):

https://wiki.mozilla.org/Thunderbird/Thunderbird11.0SupportIssues#Not_so_minor
https://bugzilla.mozilla.org/show_bug.cgi?id=733731
http://hg.mozilla.org/releases/comm-beta/rev/151697a4635b

The patch in the third URL is a two-liner which removes it, but Mozilla won't push it out until v.12, so can this be applied as an RPM patch to the F16/17 Thunderbird?
Comment 4 Dimitri Papadopoulos 2012-03-28 14:32:03 EDT
Created attachment 573426 [details]
thunderbird-bin stack trace

Same here with Thunderbird 11.0 on Fedora 16.

Please find a similar stack trace attached.

I haven't installed debuginfo because the instructions in the wiki are wrong:
# debuginfo
debuginfo: No such file or directory
# 

I'm only running addons provided by Fedora - French language, etc.
Comment 5 Dimitri Papadopoulos 2012-03-28 15:59:09 EDT
Created attachment 573439 [details]
thunderbird freeze stack trace

I eventually managed to get a freeze stack trace as described in the wiki:

	set logging on crash_bt
	thread apply all bt full
	print DumpJSStack()
	set logging off

Please fix the wiki. To install debug info packages one runs:
	debuginfo-install thunderbird
instead of:
	debuginfo install thunderbird
Comment 6 Jan Horak 2012-03-29 03:18:01 EDT
(In reply to comment #4)
> Created attachment 573426 [details]
> thunderbird-bin stack trace
> 
> Same here with Thunderbird 11.0 on Fedora 16.
> 
> Please find a similar stack trace attached.
> 
> I haven't installed debuginfo because the instructions in the wiki are wrong:
> # debuginfo
> debuginfo: No such file or directory
> # 
> 
> I'm only running addons provided by Fedora - French language, etc.

Sorry about that typo and thank you for letting me know. It's fixed now.
Comment 7 Jan Horak 2012-03-29 03:25:18 EDT
Looks like: https://bugzilla.mozilla.org/show_bug.cgi?id=733731
which should be fixed by 11.0.1. We're going to make this update today, I'll keep you updated.
Comment 9 Dimitri Papadopoulos 2012-04-03 02:36:54 EDT
I've been using Thunderbird 11.0.1 for a few days now: it does not lock up and runs just fine.
Comment 10 Ian Malone 2012-04-03 18:04:47 EDT
thunderbird-11.0.1-1.fc16.x86_64 working here thanks, previous package was freezing.

Note You need to log in before you can comment on or make changes to this bug.