Bug 805169 - https tracker crash in lt 0.15.8
https tracker crash in lt 0.15.8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rb_libtorrent (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:618538f374ac06f36f01b317c76...
:
: 754867 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 11:55 EDT by Patrick Talbert
Modified: 2012-05-03 03:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: rb_libtorrent-0.15.9-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 16:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (7.06 KB, text/plain)
2012-03-20 11:55 EDT, Patrick Talbert
no flags Details
File: maps (27.92 KB, text/plain)
2012-03-20 11:55 EDT, Patrick Talbert
no flags Details
File: backtrace (135.90 KB, text/plain)
2012-03-20 11:55 EDT, Patrick Talbert
no flags Details

  None (edit)
Description Patrick Talbert 2012-03-20 11:55:32 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/python /usr/bin/deluged --port=58846 --config=/home/patrick/.config/deluge
comment:        The program runs normally until a torrent is started. You can, for example, add a torrent in a paused state, which works fine, but then the program crashes as soon as you unpause the torrent.
crash_function: get_io_service
executable:     /usr/bin/python
kernel:         3.2.10-1.fc16.x86_64
pid:            11697
pwd:            /home/patrick
reason:         Process /usr/bin/python was killed by signal 11 (SIGSEGV)
time:           Sun 18 Mar 2012 02:40:25 PM EDT
uid:            1000
username:       patrick

backtrace:      Text file, 139166 bytes
dso_list:       Text file, 7234 bytes
maps:           Text file, 28594 bytes

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=25
:HOSTNAME=poodora.schiznet
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=8cb4a8dee94f9b0ca7aa009e00000055-1331961748.178908-88621569
:GNOME_KEYRING_CONTROL=/tmp/keyring-Lz73Df
:IMSETTINGS_MODULE=none
:USER=patrick
:USERNAME=patrick
:MAIL=/var/spool/mail/patrick
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/patrick/.local/bin:/home/patrick/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/patrick
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=25349
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/patrick
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=patrick
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-ChhoHf1xxT,guid=436e8e5df97f1eed9c17ea35000081e7
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/patrick
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-patrick-Ef9nrO/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/25356,unix/unix:/tmp/.ICE-unix/25356
:SSH_AUTH_SOCK=/tmp/keyring-Lz73Df/ssh
:GPG_AGENT_INFO=/tmp/keyring-Lz73Df/gpg:0:1
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-deluge.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=11561
:ORBIT_SOCKETDIR=/tmp/orbit-patrick

smolt_data:
:
:
:General
:=================================
:UUID: c98e1a34-83ed-44c2-ab69-e7e89351dc84
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4800.01
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 4
:CPU Speed: 2403
:System Memory: 5971
:System Swap: 2045
:Vendor: ECS
:System: P45T-A 1.0
:Form factor: Desktop
:Kernel: 3.2.10-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11817:32902:0) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(32902:11808:4121:9815) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11809:4121:9815) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(6523:9057:4121:9057) pci, ahci, STORAGE, JMB361 AHCI/IDE
:(6523:9057:4121:9057) pci, pata_jmicron, STORAGE, JMB361 AHCI/IDE
:(32902:14896:4121:9815) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
:(32902:14882:4121:9815) pci, ahci, STORAGE, 82801JI (ICH10 Family) SATA AHCI Controller
:(32902:14870:4121:9815) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
:(4523:28738:4523:4523) pci, sata_mv, SCSI, 88SX7042 PCI-e 4-port SATA-II
:(32902:14901:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
:(32902:9294:4121:9815) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:14905:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #6
:(32902:14902:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
:(32902:14906:4121:9815) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
:(32902:14908:4121:9815) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
:(6505:4134:4121:4134) pci, ATL1E, ETHERNET, AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
:(32902:14912:4121:10612) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 1
:(32902:14920:4121:10612) pci, pcieport, PCI/PCI, 82801JI (ICH10 Family) PCI Express Root Port 5
:(32902:14910:4121:10612) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
:(32902:14903:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
:(32902:14900:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
:(4318:403:4318:1056) pci, nvidia, VIDEO, G80 [GeForce 8800 GTS]
:(32902:14904:4121:9815) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-64c5ba6a-4e13-4f46-bab1-199d24b3fcc1 / btrfs 4096 4096 3145216 1583233 1202805 0 0 0
:/dev/sda1 /boot ext4 1024 1024 508745 419805 394205 128016 127789 127789
:/dev/mapper/luks-8afd63f8-0139-4e8f-bd25-22713b797f56 /home btrfs 4096 4096 10854912 10266302 9745764 0 0 0
:/dev/sdb WITHHELD btrfs 4096 4096 488383409 145407369 41872802 0 0 0
:/dev/sdb WITHHELD btrfs 4096 4096 488383409 145407369 41872802 0 0 0
:/dev/sdb WITHHELD btrfs 4096 4096 488383409 145407369 41872802 0 0 0
:

var_log_messages:
:Mar 18 14:38:46 poodora abrt[11583]: Saved core dump of pid 11579 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-03-18-14:38:45-11579 (56954880 bytes)
:Mar 18 14:39:35 poodora abrt[11637]: Saved core dump of pid 11633 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-03-18-14:39:34-11633 (56926208 bytes)
:Mar 18 14:40:18 poodora yum[11689]: Installed: python-beaker-1.5.4-1.fc16.noarch
:Mar 18 14:40:18 poodora yum[11689]: Installed: python-markupsafe-0.11-3.fc15.x86_64
:Mar 18 14:40:18 poodora yum[11689]: Installed: python-mako-0.4.2-1.fc16.noarch
:Mar 18 14:40:26 poodora abrt[11701]: Saved core dump of pid 11697 (/usr/bin/python) to /var/spool/abrt/ccpp-2012-03-18-14:40:25-11697 (62115840 bytes)
Comment 1 Patrick Talbert 2012-03-20 11:55:35 EDT
Created attachment 571457 [details]
File: dso_list
Comment 2 Patrick Talbert 2012-03-20 11:55:37 EDT
Created attachment 571458 [details]
File: maps
Comment 3 Patrick Talbert 2012-03-20 11:55:40 EDT
Created attachment 571459 [details]
File: backtrace
Comment 4 Calum 2012-03-20 15:36:45 EDT
This looks like https crash which is fixed in lt 0.15.9
Comment 5 Calum 2012-03-20 15:47:38 EDT
*** Bug 799736 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-03-20 17:15:45 EDT
rb_libtorrent-0.15.9-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc16
Comment 7 Fedora Update System 2012-03-20 17:15:50 EDT
rb_libtorrent-0.15.9-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc15
Comment 8 Fedora Update System 2012-03-20 17:15:58 EDT
rb_libtorrent-0.15.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/rb_libtorrent-0.15.9-1.fc17
Comment 9 Calum 2012-03-20 18:12:11 EDT
*** Bug 754867 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-03-21 14:19:31 EDT
Package rb_libtorrent-0.15.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rb_libtorrent-0.15.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4362/rb_libtorrent-0.15.9-1.fc17
then log in and leave karma (feedback).
Comment 11 leigh scott 2012-03-28 08:26:55 EDT
rb_libtorrent-0.15.9-1 will stay in updates-testing forever unless karma is received.
Comment 12 Fedora Update System 2012-05-02 16:52:36 EDT
rb_libtorrent-0.15.9-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-05-03 03:28:44 EDT
rb_libtorrent-0.15.9-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.