Bug 805192 - migration 35 is very slow when lots of errata are present
migration 35 is very slow when lots of errata are present
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.0.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
wes hayutin
:
Depends On:
Blocks: 805193 805195
  Show dependency treegraph
 
Reported: 2012-03-20 12:22 EDT by James Slagle
Modified: 2012-05-01 14:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
C: When many errata are installed on a RHUI system, the pulp-migrate command ran very slowly. C: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, could take over two hours to perform the update process with pulp-migrate. F: The pulp-migrate command was re-written to be nore efficient on RHUI systems with many errata. R: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, should now take around forty-five minutes to perform the update process with pulp-migrate. Final: * When many errata are installed on a RHUI system, the pulp-migrate command ran very slowly. RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, could take over two hours to perform the update process with pulp-migrate. The pulp-migrate command was re-written to be more efficient on RHUI systems with many errata. RHUI systems with many errata should now take around forty-five minutes to perform the update process with pulp-migrate. (BZ#805192)
Story Points: ---
Clone Of:
: 805193 (view as bug list)
Environment:
Last Closed: 2012-05-01 14:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Slagle 2012-03-20 12:22:04 EDT
migration 35 is very slow when lots of errata are present

The EC2 rhui's have 3000+ errata and migration 35 is taking 2+ hours to run.
Comment 1 James Slagle 2012-03-20 12:24:27 EDT
Because this is RHUI and no one has yet migrated past version 35, we can modify migration version 35 directly.  This will make it so that we can add the needed indexes and rewrite the slow part of the migration to be much more efficient.

We can do these same changes in pulp, but we need an additional migration (version 39) to add the indexes.

We can then also pull migration 39 back into rhui so that the 2 branches stay on the same db version.  version 39 will essentially be a no-op in the rhui branch since the indexes were already added as part of 35.
Comment 2 James Slagle 2012-03-20 12:30:19 EDT
commits 493dcab291438644bb8c433de9254acfbcef5245 and feddbea87e443e55175fdb3d4095120e97beba31 in pulp rhui branch
Comment 3 James Slagle 2012-03-23 09:21:20 EDT
QA:
the pulp-migrate command during the update process should run quicker than it did before.  Previously, on a RHUI with all of RHEL 5 and RHEL 6 sync'd and a few layered products, it was taking at least 2 hours.  It should now take closer to 45 minutes.

If you don't have a good way to test this, then just verifying that the update process works is sufficient.
Comment 4 mkovacik 2012-04-02 14:12:36 EDT
Upgrade both from 2.0.1 and 2.0.2 works well.
Comment 5 Lana Brindley 2012-04-19 20:58:06 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
C: When many errata are installed on a RHUI system, the pulp-migrate command ran very slowly.
C: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, could take over two hours to perform the update process with pulp-migrate.
F: The pulp-migrate command was re-written to be nore efficient on RHUI systems with many errata.
R: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, should now take around forty-five minutes to perform the update process with pulp-migrate.
Comment 6 Lana Brindley 2012-04-20 00:26:40 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,7 @@
 C: When many errata are installed on a RHUI system, the pulp-migrate command ran very slowly.
 C: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, could take over two hours to perform the update process with pulp-migrate.
 F: The pulp-migrate command was re-written to be nore efficient on RHUI systems with many errata.
-R: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, should now take around forty-five minutes to perform the update process with pulp-migrate.+R: RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, should now take around forty-five minutes to perform the update process with pulp-migrate.
+
+Final:
+* When many errata are installed on a RHUI system, the pulp-migrate command ran very slowly. RHUI systems with Red Hat Enterprise Linux 5, Red Hat Enterprise Linux 6, and some layered products installed and updated, could take over two hours to perform the update process with pulp-migrate. The pulp-migrate command was re-written to be more efficient on RHUI systems with many errata. RHUI systems with many errata should now take around forty-five minutes to perform the update process with pulp-migrate. (BZ#805192)
Comment 7 errata-xmlrpc 2012-05-01 14:37:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0539.html

Note You need to log in before you can comment on or make changes to this bug.