Bug 805213 - Interface spins when adding package to template
Interface spins when adding package to template
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 12:48 EDT by Steve Reichard
Modified: 2014-09-18 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (94.31 KB, image/png)
2012-03-20 12:48 EDT, Steve Reichard
no flags Details

  None (edit)
Description Steve Reichard 2012-03-20 12:48:38 EDT
Created attachment 571472 [details]
screen shot

Description of problem:

Because of BZ 805202 I needed to add packages to a template by browsing in the left pane, however my first attempt the interface just spun (waited 15+ minutes).

See attached screen shot.

Version-Release number of selected component (if applicable):

beta 5 

[root@cf-se1 ~]# /pub/scripts/post_install_configuration_scripts/cf-se-versions 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Linux cf-se1.cloud.lab.eng.bos.redhat.com 2.6.32-220.7.1.el6.x86_64 #1 SMP Fri
Feb 10 15:22:22 EST 2012 x86_64 x86_64 x86_64 GNU/Linux
PyYAML-3.09-14.el6_1.x86_64
facter-1.5.9-1.el6.noarch
js-1.8.5-6.el6.x86_64
mongodb-1.8.2-3.el6.x86_64
mongodb-server-1.8.2-3.el6.x86_64
puppet-2.6.14-1.el6.noarch
pymongo-1.9-8.el6_1.x86_64
tomcat6-6.0.24-35.el6_1.noarch
ruby-1.8.7.352-6.el6.x86_64
grinder-0.0.139-1.el6.noarch
postgresql-server-8.4.9-1.el6_1.1.x86_64
postgresql-8.4.9-1.el6_1.1.x86_64
candlepin-0.5.26-1.el6.noarch
pulp-1.0.0-4.el6.noarch
katello-0.1.304-1.el6.noarch
katello-all-0.1.304-1.el6.noarch
katello-cli-0.1.104-1.el6.noarch
katello-configure-0.1.104-1.el6.noarch
[root@cf-se1 ~]# 



How reproducible:

not sure at this time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hugh Brock 2012-03-20 14:30:18 EDT
If this is a real issue, it might be a blocker -- is it?
Comment 3 Brad Buckingham 2012-03-21 13:17:55 EDT
After debugging on the environment that is showing the problem, found that the build did not include a couple of commits that recently went in under a bug for 'search consistency'.  That was bug 790063.  Refer to the bug for details on the commits.

Temporarily monkey patched a few files on the environment and confirmed that with those changes adding the packages mentioned (e.g. open-vm-tools and aeolus-audrey-agent) worked correctly.  The files included in the patch were app/controllers/repositories_controller.rb, app/models/glue/pulp/package.rb and lib/util/search.rb.  (Note: the monkey patch has since been backed out.)
Comment 4 Garik Khachikyan 2012-03-22 07:25:20 EDT
please: we need a concrete scenario to test/assure that issue has fixed.

what repo/package is adding to the template and so.
Comment 9 Corey Welton 2012-04-19 12:05:30 EDT
QA Verified in brew for CloudForms System Engine Version: 0.1.310-1.el6_2
Comment 10 errata-xmlrpc 2012-05-15 14:57:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html
Comment 11 Mike McCune 2013-08-16 13:57:01 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.