Bug 805226 - gnome-keyring prompt for SSH key password multiple times when running ssh concurrently
gnome-keyring prompt for SSH key password multiple times when running ssh con...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-keyring (Show other bugs)
6.2
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Matthias Clasen
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 13:00 EDT by Martin
Modified: 2017-12-06 07:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 07:02:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-03-20 13:00:23 EDT
Description of problem:
gnome-keyring prompt for SSH key password multiple times when running ssh concurrently

Version-Release number of selected component (if applicable):
Name        : gnome-keyring
Arch        : x86_64
Version     : 2.28.2
Release     : 7.el6

How reproducible:
always

Steps to Reproduce:
1. run: "while [[ $I -lt 10 ]]; do ssh testuser@localhost& ((I+=1)); done"
  
Actual results:
gnome-keyring ask for SSH key password once for each connection

Expected results:
gnome-keyring should ask for SSH key password only once

Additional info:
when running single "ssh testuser@localhost" gnome-keyring ask for SSH key password - that's ok
when running "while [[ $I -lt 10 ]]; do ssh testuser@localhost& ((I+=1)); done" after that, gnome-keyring remembers SSH key password and doesn't ask again
Comment 2 RHEL Product and Program Management 2012-05-03 01:14:14 EDT
Since RHEL 6.3 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 07:02:11 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.