Bug 805265 - Provide the URL and default login information upon successful setup
Provide the URL and default login information upon successful setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
Tazim Kolhar
: Triaged
: 885208 1003000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 14:23 EDT by Og Maciel
Modified: 2014-07-02 10:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:07:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-03-20 14:23:30 EDT
Description of problem:

After one finishes installing katello (i.e. running katello-configure in the command line), it would be extremely benefitial (not to mention user friendly) if we could output a small notification message stating:

* Where one can find the web ui:
  "Please point your browser to https://$HOSTNAME/{cfse|sam|katello}
* The default login information:
  "Login using admin for your username and admin for your password. Please make sure to update your password as soon as possible!!!"

The reason here is to make the experience a bit friendlier to the person doing the installation, as well as avoid an avalanche of possible issues related to question about where to log in and what username/password to use.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. run katello-configure
2.
3.
  
Actual results:

Once the installation is done, you get absolutely no feedback whatsoever as to what the next step is.

Expected results:


Additional info:
Comment 1 Og Maciel 2012-03-20 14:25:28 EDT
Here's what the user gets:

[root@qetello01 ~]# katello-configure:
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20120320-104949/main.log]
Creating Katello database user
############################################################ ... OK
Creating Katello database
############################################################ ... OK
Creating Candlepin database user
############################################################ ... OK
Creating Candlepin database
############################################################ ... OK
Candlepin setup
############################################################ ... OK
Populating Katello database schema
############################################################ ... OK
Initializing Katello data
############################################################ ... OK
[root@qetello01 ~]#
Comment 2 Mike McCune 2012-03-20 17:15:54 EDT
A simple change that will help the usability of the installer.  Lets do this in 1.1
Comment 4 Mike McCune 2013-07-08 13:47:23 EDT
*** Bug 885208 has been marked as a duplicate of this bug. ***
Comment 5 sthirugn@redhat.com 2013-08-30 12:10:27 EDT
*** Bug 1003000 has been marked as a duplicate of this bug. ***
Comment 9 Bryan Kearney 2014-05-09 11:05:31 EDT
delivered in katello-installer-0.0.37-1.el6sat.noarch
Comment 10 Tazim Kolhar 2014-05-20 03:43:29 EDT

$ katello-installer
  Success!
  * Katello is running at https://qetello02.usersys.redhat.com
      Default credentials are 'admin:changeme'
  * Capsule is running at https://qetello02.usersys.redhat.com:9090
  * To install additional capsule on separate machine continue by running:"

      capsule-certs-generate --capsule-fqdn "$CAPSULE" --certs-tar "~/$CAPSULE-certs.tar"

  The full log is at /var/log/katello-installer/katello-installer.log
Comment 11 Bryan Kearney 2014-07-02 10:07:34 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.