Bug 805324 - Lucene syntax for searches in promotion section is not working correctly
Lucene syntax for searches in promotion section is not working correctly
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 17:28 EDT by Og Maciel
Modified: 2014-09-18 11:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 14:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-03-20 17:28:11 EDT
Description of problem:

In the promotions section, if you choose Product --> Packages and then search using name:foo nothing is returned. If you search using name: foo (note the space after the colon), then the equivalent of foo* is returned.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Searching for name: foo should only return perfect matches for packages with name foo.

Additional info:
Comment 1 Justin Sherrill 2012-03-20 17:33:06 EDT
Note to self:


 In app controller (working correctly) we do:

 !AppConfig.simple_search_tokens.any?{|s| search.downcase.match(s)}

 but in promotion packges (not working) we do:                
 AppConfig.simple_search_tokens.any?{|s| !query_down.match(s)}


 notice the swap of the !  char
Comment 3 Justin Sherrill 2012-03-23 14:05:16 EDT
katello commit

30be04bc75a004987bf3ed5bc063fd8cce36fb8d

few changes here:

Change to use default field instead of analysing if the user used a special char or not.  Made package name be a keyword analyzed field.  Created new field for auto complete called 'name_autocomplete' that is analyzed with the special ngramming made for auto complete.  Improved autocomplete to do a maximum of 20 grams (up from 10).
Comment 6 Corey Welton 2012-04-02 11:05:40 EDT
QA Verified using a google chrome repo

Search for "goo" returns nothing
Search for "goo*" returns valid results
Search for "goo " returns nothing
Comment 7 errata-xmlrpc 2012-05-15 14:57:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0665.html

Note You need to log in before you can comment on or make changes to this bug.