Bug 805367 - Remove unnecessary Qpid headers and linking so Qpid ABI remains stable
Remove unnecessary Qpid headers and linking so Qpid ABI remains stable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari (Show other bugs)
6.3
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jeff Peeler
IDM QE LIST
: ZStream
Depends On:
Blocks: 806766 806948
  Show dependency treegraph
 
Reported: 2012-03-20 23:19 EDT by Jeff Peeler
Modified: 2016-04-26 09:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
: 806948 806949 806950 (view as bug list)
Environment:
Last Closed: 2012-06-20 09:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Peeler 2012-03-20 23:19:08 EDT
Description of problem:
The older legacy interfaces of Qpid are not ABI stable, which means Matahari would need to be rebuilt for subsequent Qpid changes. 

How reproducible:
Always

Steps to Reproduce:
1.Build Matahari
  
Actual results:
Matahari build completes utilizing unstable ABI.

Expected results:
Matahari build completes utilizing only the stable ABI.

Additional info:
For this change, the qpid::sys symbols were checked to no longer be present in the binaries.
Comment 3 Jeff Peeler 2012-03-21 11:56:13 EDT
The changes here were tested by examining the binaries and looking for qpid::sys symbols: objdump -T <binary> | grep qpid | grep sys.
Comment 10 Zane Bitter 2012-04-26 04:38:35 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 11 Dave Johnson 2012-05-14 09:44:24 EDT
good to go across all supported platforms using matahari v0.6.0-14
Comment 13 errata-xmlrpc 2012-06-20 09:48:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0844.html

Note You need to log in before you can comment on or make changes to this bug.