Bug 805395 - some xfc4 icons not shown after F17 alpha gnome/xfce install
some xfc4 icons not shown after F17 alpha gnome/xfce install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 03:03 EDT by Stan King
Modified: 2014-01-21 18:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 07:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen dump of "appearances -> icons" window. (20.49 KB, image/png)
2012-03-26 02:24 EDT, Stan King
no flags Details

  None (edit)
Description Stan King 2012-03-21 03:03:22 EDT
Description of problem:

After doing an install from the Fedora 17 Alpha DVD, with both the gnome and xfce desktop environments selected, some of the icons were missing from the panels and the menus.

For example, the icon for Terminal was not shown, although space for it was reserved, and the Terminal was started when clicked upon.

I remedied this by running Settings -> Appearance, where I noticed that none of the 5 settings were highlighted on the "Icons" tab.  Selecting one of them has fixed the problem.

By the way, this was not a problem when installing from the xfce Live CD.


Version-Release number of selected component (if applicable):

Fedora 17 Alpha, installed from DVD


How reproducible:


Steps to Reproduce:
1. Install Fedora 17 Alpha from the DVD, with both gnome and xfce desktop environments selected.
2.
3.
  
Actual results:

Some xfce panel and menu icons, such as that for Terminal, are blank.


Expected results:

All icons present.


Additional info:

Problem can be resolved by choosing an Icon setting in the Appearance settings, so it seems to be just a problem of the initial state after installation.
Comment 1 Kevin Fenzi 2012-03-23 19:36:48 EDT
Strange. Will see if I can track down whats happening here.
Comment 2 Kevin Fenzi 2012-03-25 20:31:00 EDT
Is/was "Fedora" one of the options there? or can you list out which ones are showing as available there?
Comment 3 Stan King 2012-03-26 02:24:12 EDT
Created attachment 572658 [details]
Screen dump of "appearances -> icons" window.

This window had none of these five choices selected when I opened it initially.

If I remember right, the problem of missing icons went away immediately upon selecting GNOME.
Comment 4 Kevin Fenzi 2012-03-26 11:31:39 EDT
Christoph: Did "Fedora" icon theme go away? Should we switch default to "GNOME" ?
Comment 5 Christoph Wickert 2012-03-27 07:26:15 EDT
No, it's still there. fedora-icon-theme is just some Fedora icons plus the mist theme from GNOME.

As we patch Xfce to use Fedora by default, I think we should add it to the xfce-desktop group in comps. This is better than adding a hard dependency somewhere. I think 'default' should be sufficient as I don't want to make it 'mandatory'.

Fixed in http://git.fedorahosted.org/git/?p=comps.git;a=commit;h=f85b8e40

Note You need to log in before you can comment on or make changes to this bug.