Bug 805403 - Guest hung in the beginning of installation (only AMD host)
Guest hung in the beginning of installation (only AMD host)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 03:41 EDT by Golita Yue
Modified: 2013-01-09 19:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 10:12:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (10.21 KB, image/png)
2012-03-21 03:43 EDT, Golita Yue
no flags Details

  None (edit)
Description Golita Yue 2012-03-21 03:41:46 EDT
Description of problem:
Install a guest, the guest hung at "windows is loading files..." with -cpu Opteron_G3 in AMD host. (please refer to the screenshot)

Hit this bug with guest -- win7 32&64 , win2008r2 

Version-Release number of selected component (if applicable):
kernel 2.6.32-251.el6.x86_64
qemu-kvm-0.12.1.2-2.251.el6.x86_64

How reproducible:
easy

Steps to Reproduce:
1. install a guest with -cpu Opteron_G3 in AMD host.

cmd:
/usr/libexec/qemu-kvm -drive file='/home/images/win2008r2-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,format=qcow2,aio=threads -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 -device virtio-net-pci,netdev=idGR0l1d,mac=9a:e3:a9:0d:65:70,id=ndev00idGR0l1d,bus=pci.0,addr=0x3 -netdev tap,id=idGR0l1d,vhost=on,script=/etc/qemu-ifup-switch -m 4096 -smp 2,cores=1,threads=1,sockets=2 -drive file='/home/autotest/client/tests/kvm/isos/ISO/Win2008R2/en_windows_server_2008_r2_standard_enterprise_datacenter_and_web_with_sp1_x64_dvd_617601.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file='/home/autotest/client/tests/kvm/isos/windows/virtio-win.iso',index=3,if=none,id=drive-ide0-1-0,media=cdrom,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -cpu Opteron_G3 -fda '/home/autotest/client/tests/kvm/images/win2008-r2-64/answer.vfd' -vnc :0 -rtc base=localtime,clock=host,driftfix=slew -M rhel6.3.0 -boot order=cdn,once=d,menu=off   -enable-kvm -monitor stdio

2. check guest status
(qemu) info status
VM status: running
  
Actual results:
The guest hung at "windows is loading files...".

Expected results:
Can install a guest.

Additional info:

------ Host top info: ------
[root@amd-9600b-8-2 ~]# top

top - 15:29:39 up 37 min,  3 users,  load average: 0.99, 0.59, 0.40
Tasks: 151 total,   1 running, 150 sleeping,   0 stopped,   0 zombie
Cpu(s): 11.7%us, 13.4%sy,  0.0%ni, 74.9%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   7865532k total,   690916k used,  7174616k free,     8016k buffers
Swap: 16777208k total,        0k used, 16777208k free,   247940k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                         
 8366 root      20   0 4515m 217m 4232 S 100.1  2.8   3:55.82 qemu-kvm                                                       
    8 root      20   0     0    0    0 S  6.3  0.0   0:16.82 ksoftirqd/1                                                     
 8402 root      20   0 15020 1288  948 R  0.3  0.0   0:00.11 top                                                             
    1 root      20   0 19348 1524 1204 S  0.0  0.0   0:01.09 init                                                            
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.01 kthreadd   
  

------ Host cpu info: ------
processor       : 3
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 2
model name      : AMD Phenom(tm) 9600B Quad-Core Processor
stepping        : 3
cpu MHz         : 2300.000
cache size      : 512 KB
physical id     : 0
siblings        : 4
core id         : 3
cpu cores       : 4
apicid          : 3
initial apicid  : 3
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs npt lbrv svm_lock
bogomips        : 4609.50
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate
Comment 1 Golita Yue 2012-03-21 03:43:39 EDT
Created attachment 571618 [details]
screen shot
Comment 3 Golita Yue 2012-03-21 06:47:59 EDT
The following are my testing results:

1. Hit this bug only in AMD host. the host cpuinfo please refer to Comment#0.
   Didn't hit this bug in Intel host.

2. Didn't hit this bug in the following AMD host:
processor	: 1
vendor_id	: AuthenticAMD
cpu family	: 15
model		: 107
model name	: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
stepping	: 2
cpu MHz		: 1000.000
cache size	: 512 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv
bogomips	: 2004.12
TLB size	: 1024 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual
power management: ts fid vid ttp tm stc 100mhzsteps
Comment 4 Golita Yue 2012-03-21 07:06:04 EDT
This bug can be reproduced with following two conditions:
1. virtio_nic,virtio_blk 
2. ide,rtl8139
Comment 5 Dor Laor 2012-03-21 09:24:43 EDT
Is that a regression? Meaning is 6.2 code does not have issues w/ it?
Comment 6 Golita Yue 2012-03-22 02:49:30 EDT
(In reply to comment #5)
> Is that a regression? Meaning is 6.2 code does not have issues w/ it?

Tested in 6.2, can hit this bug.
qemu-kvm-0.12.1.2-2.209.el6.x86_64
kernel-2.6.32-220.el6.x86_64
Comment 8 Eduardo Habkost 2012-04-11 09:41:41 EDT
Golita Yue: can I get access to the host where this bug can be reproduced, and the required ISO and VFD images? I can't reproduce it without them.
Comment 11 Golita Yue 2012-04-16 23:26:47 EDT
(In reply to comment #8)
> Golita Yue: can I get access to the host where this bug can be reproduced, and
> the required ISO and VFD images? I can't reproduce it without them.

Eduardo, I will reserve that machine from virtlab, then will tell you the host ip in irc.
Comment 12 Golita Yue 2012-05-02 06:04:41 EDT
Eduardo, 
Tested 100 times with host amd-9600b-8-2, but didn't reproduce this bug.
Comment 13 Miya Chen 2012-05-02 06:33:00 EDT
(In reply to comment #12)
> Eduardo, 
> Tested 100 times with host amd-9600b-8-2, but didn't reproduce this bug.

Hi Golita, could you please update the version of kernel and qemu? And also what kind of guests you tested? thanks.
Comment 14 Golita Yue 2012-05-02 23:26:47 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > Eduardo, 
> > Tested 100 times with host amd-9600b-8-2, but didn't reproduce this bug.
> 
> Hi Golita, could you please update the version of kernel and qemu? And also
> what kind of guests you tested? thanks.

Tested in following version:
kernel-2.6.32-262.el6.x86_64,qemu-kvm-0.12.1.2-2.276.el6
kernel-2.6.32-220.el6.x86_64,qemu-kvm-0.12.1.2-2.209.el6
guest: win2008r2
cmd: use the same as comments #0

Note You need to log in before you can comment on or make changes to this bug.