Bug 805427 - idnssoaserial does not honour the recommended syntax in rfc1912.
idnssoaserial does not honour the recommended syntax in rfc1912.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 05:35 EDT by Gowrishankar Rajaiyan
Modified: 2015-05-20 11:17 EDT (History)
5 users (show)

See Also:
Fixed In Version: ipa-2.2.0-6.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0819 normal SHIPPED_LIVE ipa bug fix and enhancement update 2012-06-19 16:34:17 EDT

  None (edit)
Description Gowrishankar Rajaiyan 2012-03-21 05:35:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):
ipa-server-2.2.0-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
[root@primenova ~]# date
Wed Mar 21 04:21:29 EDT 2012
[root@primenova ~]# 

[root@primenova ~]# ipa dnszone-show lab.eng.pnq.redhat.com
  Zone name: lab.eng.pnq.redhat.com
  Authoritative nameserver: primenova.lab.eng.pnq.redhat.com.
  Administrator e-mail address: hostmaster.lab.eng.pnq.redhat.com.
  SOA serial: 2012210301        <<<<<<<<<
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  Active zone: TRUE
  Allow query: any;
  Allow transfer: none;
[root@primenova ~]#  


Actual results:
SOA serial: 2012210301 (YYYYDDMMnn)

Expected results:
SOA serial: 2012032101 (YYYYMMDDnn)

Additional info:
The recommended syntax is YYYYMMDDnn (YYYY=year, MM=month, DD=day, nn=revision number.) Ref: http://www.ietf.org/rfc/rfc1912.txt
Comment 2 Martin Kosek 2012-03-21 05:52:09 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2567
Comment 5 Steeve Goveas 2012-04-09 07:24:53 EDT
[root@wheeljack ~]# rpm -qa | grep ipa-server
ipa-server-2.2.0-8.el6.x86_64

[root@wheeljack ~]# ipa dnszone-show lab.phd.pnq.redhat.net
  Zone name: lab.phd.pnq.redhat.net
  Authoritative nameserver: wheeljack.lab.eng.pnq.redhat.com.
  Administrator e-mail address: hostmaster.lab.phd.pnq.redhat.net.
  SOA serial: 2012040901
  SOA refresh: 3600
  SOA retry: 900
  SOA expire: 1209600
  SOA minimum: 3600
  Active zone: TRUE
  Allow query: any;
  Allow transfer: none;

[root@wheeljack ~]# date
Mon Apr  9 07:05:32 EDT 2012
[root@wheeljack ~]#

Expected results:
SOA serial: 2012040901 (YYYYMMDDnn)

Verified in package ipa-server-2.2.0-8.el6.x86_64
Comment 7 Martin Kosek 2012-04-25 05:31:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 09:25:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0819.html
Comment 10 Petr Spacek 2012-11-09 04:49:13 EST
IPA 3.0 with bind-dyndb-ldap version 2.0 will not follow RFC1912 syntax by design. Please do not reopen this bug.

New syntax is unix timestamp - number of seconds from midnight 1.1.1970.

Note You need to log in before you can comment on or make changes to this bug.