Bug 805434 - checked.inlines.hh:638: internal compiler error: in invert_truthvalue, at fold-const.c:2700
checked.inlines.hh:638: internal compiler error: in invert_truthvalue, at fol...
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gcc (Show other bugs)
x86_64 Linux
unspecified Severity unspecified
: rc
: 4.9
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2012-03-21 05:57 EDT by ntuduc
Modified: 2012-06-20 12:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-06-20 12:08:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Preprocessed source when running the command "make" (2.85 MB, application/octet-stream)
2012-03-21 05:57 EDT, ntuduc
no flags Details

  None (edit)
Description ntuduc 2012-03-21 05:57:17 EDT
Created attachment 571665 [details]
Preprocessed source when running the command "make"

Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install gmp-5.0.4.tar.bz2 with configuration:
    ./configure --prefix=/my/install/dir CC=c99 --enable-cxx --enable-assert --enable-alloca --enable-old-fft-full --enable-mpbsd --enable-shared
    make check
    make install
2. Install ppl-0.12 with configuration:
    ./configure --prefix=/my/install/dir CC=c99 --with-gmp=$gtk
Actual results: output when I run the command "make"

Making all in utils
make[2]: Entering directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/utils'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/utils'
Making all in src
make[2]: Entering directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/src'
make  all-am
make[3]: Entering directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/src'
/bin/sh ../libtool  --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I..  -I.. -I../src -I/nas/projects/soft/sim/usr/duc/mylib/gcc/include -I/nas/projects/soft/sim/usr/duc/mylib/gcc/include  -g -O2 -frounding-math  -W -Wall -MT Box.lo -MD -MP -MF .deps/Box.Tpo -c -o Box.lo Box.cc
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I.. -I.. -I../src -I/nas/projects/soft/sim/usr/duc/mylib/gcc/include -I/nas/projects/soft/sim/usr/duc/mylib/gcc/include -g -O2 -frounding-math -W -Wall -MT Box.lo -MD -MP -MF .deps/Box.Tpo -c Box.cc  -fPIC -DPIC -o .libs/Box.o
In file included from checked.defs.hh:680,
                 from Checked_Number.defs.hh:28,
                 from Coefficient.types.hh:16,
                 from Coefficient.defs.hh:27,
                 from Box.defs.hh:29,
                 from Box.cc:25:
checked.inlines.hh: In function `Parma_Polyhedra_Library::Result Parma_Polyhedra_Library::Checked::input_generic(Type&, std::istream&, Parma_Polyhedra_Library::Rounding_Dir)':
checked.inlines.hh:638: internal compiler error: in invert_truthvalue, at fold-const.c:2700
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccbVqhwC.out file, please attach this to your bugreport.
make[3]: *** [Box.lo] Error 1
make[3]: Leaving directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/nas/projects/soft/sim/usr/duc/mylib/src2/ppl-0.12'
make: *** [all] Error 2

Expected results:

Additional info:
Comment 2 ntuduc 2012-03-21 23:11:42 EDT

The machine information on which I ran this configuration:
Linux version 2.6.9-67.ELsmp (brewbuilder@hs20-bc1-5.build.redhat.com) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-8)) #1 SMP Wed Nov 7 13:56:44 EST 2007
Comment 3 Jiri Pallich 2012-06-20 12:08:11 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.