Bug 805452 - Unable to lookup user, group, netgroup aliases with case_sensitive=false.
Unable to lookup user, group, netgroup aliases with case_sensitive=false.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stephen Gallagher
IDM QE LIST
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 06:58 EDT by Kaushik Banerjee
Modified: 2012-06-20 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.8.0-20.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
: 827469 (view as bug list)
Environment:
Last Closed: 2012-06-20 07:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sssd_LDAP.log after excuting "id user_cs1" (21.01 KB, application/octet-stream)
2012-03-21 06:58 EDT, Kaushik Banerjee
no flags Details

  None (edit)
Description Kaushik Banerjee 2012-03-21 06:58:09 EDT
Created attachment 571681 [details]
sssd_LDAP.log after excuting "id user_cs1"

Description of problem:
Unable to lookup user, group, netgroup aliases with case_sensitive=false.

Version-Release number of selected component (if applicable):
sssd-1.8.0-17

How reproducible:
Always

Steps to Reproduce:
1. Add the following user, group and netgroup on ldap server:

dn: uid=User_CS1,ou=Users,dc=example,dc=com
uidNumber: 1111111
gidNumber: 1111111
objectClass: posixAccount
objectClass: account
cn: User_CS1
homeDirectory: /home/User_CS1
userPassword:: U2VjcmV0MTIz
uid: User_CS1_Alias
uid: User_CS1

dn: cn=User_CS1_grp1,ou=Groups,dc=example,dc=com
gidNumber: 1111111
objectClass: posixGroup
memberUid: User_CS1
cn: User_CS1_grp1_Alias
cn: User_CS1_grp1

dn: cn=NetGroup_CS1,ou=Netgroups,dc=example,dc=com
objectClass: nisNetgroup
cn: NetGroup_CS1_Alias
cn: NetGroup_CS1
nisNetgroupTriple: (Host1.example.com,User1,example.com)

2. sssd.conf domain section is as follows:
[domain/LDAP]
debug_level=0xFFF0
id_provider = ldap
ldap_uri = ldap://ldapserver.example.com
ldap_search_base = dc=example,dc=com
ldap_tls_cacert = /etc/openldap/certs/server.pem
case_sensitive = false

3. Lookup user, group and netgroup by both primary name and alias.

# id user_cs1
id: user_cs1: No such user      <== nothing is returned

# id user_cs1_alias
uid=1111111(user_cs1) gid=1111111(user_cs1_grp1) groups=1111111(user_cs1_grp1)

# getent group user_cs1_grp1   <== nothing is returned

# getent group user_cs1_grp1_alias
user_cs1_grp1:*:1111111:User_CS1

# getent netgroup netgroup_cs1_alias  <== nothing is returned

# getent netgroup netgroup_cs1
netgroup_cs1          (Host1.example.com, User1, example.com)

  
Actual results:
Unable to lookup user, group, netgroup aliases with case_sensitive=false

Expected results:
Should be able to lookup alias and primary names of user, group and netgroup.

Additional info:
Comment 2 Jakub Hrozek 2012-03-21 08:35:57 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1272
Comment 5 Kaushik Banerjee 2012-04-02 15:43:59 EDT
Verified in version:

# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.8.0                             Vendor: Red Hat, Inc.
Release     : 20.el6                        Build Date: Fri 30 Mar 2012 06:45:57 PM IST
Install Date: Mon 02 Apr 2012 05:36:37 PM IST      Build Host: x86-002.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.8.0-20.el6.src.rpm
Size        : 7865577                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon
Comment 6 Jakub Hrozek 2012-04-03 14:50:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 8 errata-xmlrpc 2012-06-20 07:56:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0747.html

Note You need to log in before you can comment on or make changes to this bug.