Bug 805459 - Tilda expansion failing in ksh
Tilda expansion failing in ksh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ksh (Show other bugs)
5.8
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Michal Hlavinka
qe-baseos-tools
: Patch, ZStream
Depends On: 802565
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 07:17 EDT by RHEL Product and Program Management
Modified: 2012-08-10 08:47 EDT (History)
10 users (show)

See Also:
Fixed In Version: ksh-20100621-5.el5_8.1
Doc Type: Bug Fix
Doc Text:
Previously, ksh did not expand the tilde (~) character properly. For example, characters in the tilde prefix were not treated as a login name but as a part of the path and the "No such file or directory" message was displayed. The underlying source code has been modified and tilde expansion now works as expected in such a scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-28 07:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-03-21 07:17:13 EDT
This bug has been copied from bug #802565 and has been proposed
to be backported to 5.8 z-stream (EUS).
Comment 6 Eliska Slobodova 2012-03-28 05:50:30 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, ksh did not expand the tilde (~) character properly. For example, characters in the tilde prefix were not treated as a login name but as a part of the path and the "No such file or directory" message was displayed. The underlying source code has been modified and tilde expansion now works as expected in such a scenario.
Comment 7 errata-xmlrpc 2012-03-28 07:17:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0432.html

Note You need to log in before you can comment on or make changes to this bug.