Bug 805495 - jBPM modules Hornetq versions are different from the product version
jBPM modules Hornetq versions are different from the product version
Status: VERIFIED
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM Console (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
unspecified Severity high
: ---
: BRMS 5.3.0.GA
Assigned To: Kris Verlaenen
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 09:25 EDT by Ryan Zhang
Modified: 2012-05-02 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Zhang 2012-03-21 09:25:59 EDT
Description of problem:
Hornetq product version for EAP 5.1.2  is  2.2.10.GA. 
The ones for jbpm modules is lower version. See below  version information.

[rzhang@localhost default]$ find . -name "hornetq-core*"
./deploy/gwt-console-server.war/WEB-INF/lib/hornetq-core-2.0.0.GA.jar
./deploy/jbpm-human-task.war/WEB-INF/lib/hornetq-core-2.2.2.Final.jar

If both gwt-console-server and jbpm-human-task.war can be upgraded to 2.2.10.Final (community version) without causing functional problem.

I am going to add one platform profile to make jBPM include 2.2.10.GA hornetq for product release and 2.2.10.Final for community release.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Ryan Zhang 2012-03-21 09:29:44 EDT
Kris, can jbpm upgrade hornetq to 2.2.10.Final since Product version needs 2.2.10.GA hornetq?
Comment 2 Ryan Zhang 2012-03-21 09:34:50 EDT
Tihomir, the same question on process desinger project.
can jbpm upgrade hornetq to 2.2.10.Final since Product version needs
2.2.10.GA hornetq?


See the hornetq version:
[rzhang@localhost default]$ find . -name "hornetq-core*"
./deploy/designer.war/WEB-INF/lib/hornetq-core-2.2.2.Final.jar
Comment 4 Tihomir Surdilovic 2012-04-05 17:15:54 EDT
Removed dependency to it in designer as it was not being used. Fix checked into designer master and 2.1.x branch.
Comment 5 Kris Verlaenen 2012-04-10 10:57:07 EDT
Still need to fix this for jbpm modules.
Comment 6 Ryan Zhang 2012-04-23 03:38:49 EDT
Update status to ON_QA. Please verify them against ER6.
Comment 7 Lukáš Petrovický 2012-05-02 03:38:08 EDT
HornetQ 2.2.10.GA is used inside the server, Designer no longer carries HornetQ,

VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.