Bug 805501 - qemu-kvm core dumped while sending system_reset to a virtio-scsi guest
qemu-kvm core dumped while sending system_reset to a virtio-scsi guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
: 835009 846920 846933 (view as bug list)
Depends On:
Blocks: 833566
  Show dependency treegraph
 
Reported: 2012-03-21 09:46 EDT by Chao Yang
Modified: 2013-02-21 02:33 EST (History)
14 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.309.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:33:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chao Yang 2012-03-21 09:46:17 EDT
Description of problem:
Launch a scsi-disk guest, sending system_reset to guest, qemu-kvm core dumped immediately.

Version-Release number of selected component (if applicable):
# rpm -q qemu-kvm; uname -r
qemu-kvm-0.12.1.2-2.253.el6.x86_64
2.6.32-251.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Program terminated with signal 11, Segmentation fault.
#0  0x00007f2c6cf92d79 in scsi_req_cancel (req=0x7f2c580070c0) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1389
1389	    if (req->bus->info->cancel) {
(gdb) bt
#0  0x00007f2c6cf92d79 in scsi_req_cancel (req=0x7f2c580070c0) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1389
#1  0x00007f2c6cf92dc5 in scsi_device_purge_requests (sdev=0x7f2c6f489010, sense=...) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-bus.c:1416
#2  0x00007f2c6cf969a7 in scsi_disk_reset (dev=0x7f2c6f489010) at /usr/src/debug/qemu-kvm-0.12.1.2/hw/scsi-disk.c:1517
#3  0x00007f2c6cf2163a in qemu_system_reset () at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:3422
#4  0x00007f2c6cf4503c in qemu_kvm_system_reset () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:1978
#5  kvm_main_loop () at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2258
#6  0x00007f2c6cf2641c in main_loop (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4331
#7  main (argc=20, argv=<value optimized out>, envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6591
(gdb)
Comment 4 RHEL Product and Program Management 2012-07-10 03:16:42 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 22:03:53 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Paolo Bonzini 2012-07-12 04:41:27 EDT
*** Bug 835009 has been marked as a duplicate of this bug. ***
Comment 7 Paolo Bonzini 2012-08-19 09:21:14 EDT
*** Bug 846920 has been marked as a duplicate of this bug. ***
Comment 8 Paolo Bonzini 2012-08-19 09:24:09 EDT
*** Bug 846933 has been marked as a duplicate of this bug. ***
Comment 9 Paolo Bonzini 2012-08-19 09:25:05 EDT
Bug 846933 has a different testcase, please make sure it is included in the virtio-win test plan for virtio-scsi.
Comment 14 Shaolong Hu 2012-10-26 01:39:30 EDT
Verified on qemu-kvm-rhev-0.12.1.2-2.331.el6.x86_64:

1. boot guest with:

usr/libexec/qemu-kvm -enable-kvm -M rhel6.4.0 -m 4G -name rhel6.3-64 -rtc base=utc,clock=host,driftfix=slew -no-kvm-pit-reinjection -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=00:24:7E:11:22:33 -boot order=cd -monitor stdio -usb -device usb-tablet,id=input0 -chardev socket,id=s1,path=/tmp/s1,server,nowait -device isa-serial,chardev=s1 -vnc :10 -monitor tcp::1234,server,nowait -qmp tcp:0:5555,server,nowait -chardev socket,id=qmp_monitor_id_qmpmonitor1,path=/tmp/qmp,server,nowait -mon chardev=qmp_monitor_id_qmpmonitor1,mode=control -drive file=RHEL-Server-6.4-64-virtio.qcow2,if=none,format=qcow2,id=disk1   -device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 -device scsi-hd,bus=scsi0.0,drive=disk1,id=scsi1

2. in qemu monitor:

(qemu) system_reset

3. guest reboot correctly.
Comment 15 errata-xmlrpc 2013-02-21 02:33:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.