Bug 805506 - JON 3.0.0 Server Patch 02 does not resolve bugzilla 785022
JON 3.0.0 Server Patch 02 does not resolve bugzilla 785022
Status: CLOSED NEXTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade (Show other bugs)
JON 3.0.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Larry O'Leary
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 09:56 EDT by bkramer
Modified: 2012-03-26 12:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 12:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2012-03-21 09:56:02 EDT
Description of problem:

This patch, among other issues, should resolve Bug 785022 - Server upgrade fails if db-uprade.xml task is unable to created index when index already exists. The problem is that the patch, in this case, has to be applied on the JON Server that hasn't been started yet and as such still has rhq.ear.raj folder and not rhq.ear. Because of that, when patch is applied and JON Server is started the following exception will be thrown:

ERROR [MainDeployer] Could not initialise deployment: file:/opt/jon-server/jon-server-3.0.0.GA/jbossas/server/default/deploy/rhq.ear/
org.jboss.deployment.DeploymentException: No META-INF/application.xml found
...

and 

ERROR [URLDeploymentScanner] Incomplete Deployment listing:

--- Incompletely deployed packages ---
org.jboss.deployment.DeploymentInfo@d75870fb { url=file:/opt/jon-server/jon-server-3.0.0.GA/jbossas/server/default/deploy/rhq.ear/ }
  deployer: org.jboss.deployment.EARDeployer@24bb6086
  status: null
  state: FAILED
  watch: file:/opt/jon-server/jon-server-3.0.0.GA/jbossas/server/default/deploy/rhq.ear/
  altDD: null
  lastDeployed: 1332330755666
  lastModified: 1328127332000
  mbeans: 

Version-Release number of selected component (if applicable):
JON 3.0.0 GA

How reproducible:
Always

Steps to Reproduce:
1. Unzip JON 3.0.0 zip file
2. Before the server is started - deploy JON 3.0.0 Server Patch 02
3. Start JON Server.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike Foley 2012-03-26 11:57:46 EDT
medium, no target release 

per bz triage (crouch, mfoley, asantos, loleary)
Comment 2 Larry O'Leary 2012-03-26 12:05:18 EDT
The only solution made available for this issue at the moment is documented in the Knowledgebase solution https://access.redhat.com/knowledge/solutions/69100. A JON 3.0.0 Installer Patch 01 had been scheduled as identified in https://bugzilla.redhat.com/show_bug.cgi?id=786297 but has not been requested/released as the workaround is the ideal solution. This issue was fixed in JON 3.0.1 so any new installs should be using JON 3.0.1 as it is the cumulative fix release of JON 3.0.0.

Note You need to log in before you can comment on or make changes to this bug.