Bug 805570 - rhev-h complains about missing /etc/multipath/wwids on boot
rhev-h complains about missing /etc/multipath/wwids on boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 11:42 EDT by Marko Myllynen
Modified: 2016-04-26 12:44 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-03-21 11:42:09 EDT
Description of problem:
Cosmetics: without multipath in use / configured rhev-h complains on boot that it can't open /etc/multipath/wwids (no such file).

Version-Release number of selected component (if applicable):
20120209
Comment 2 Mike Burns 2012-03-23 08:11:25 EDT
The problem is this file doesn't exist in the base image.  It's generated and persisted during the installation.  This means it's not available when the image is booting.  

One possible solution is to have an empty file there in the base image.
Comment 3 Fabian Deutsch 2012-03-26 09:16:38 EDT
> One possible solution is to have an empty file there in the base image.

http://gerrit.ovirt.org/#change,3097
Comment 5 Guohua Ouyang 2012-04-01 03:59:18 EDT
Verified on 6.3-20120330 build:
1. first, reproduce the bug on 6.3-20120215.0 build, during boot can see the error "cannot open file [/etc/multipath/wwids] readonly: no such file or directory".

2. verified on 6.3-20120330 build, boot cannot see the error anymore.
Comment 6 Mike Burns 2012-06-13 12:43:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note necessary
Comment 7 Stephen Gordon 2012-06-15 09:57:05 EDT
Deleted Technical Notes Contents.

Old Contents:
no tech note necessary
Comment 9 errata-xmlrpc 2012-07-19 10:19:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.