Bug 805586 - hardware profile > edit pane > "check matches" button malfunctions
hardware profile > edit pane > "check matches" button malfunctions
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: beta6
: ---
Assigned To: Matt Wagner
wes hayutin
: Regression
Depends On:
Blocks: 809873
  Show dependency treegraph
 
Reported: 2012-03-21 12:06 EDT by dgao
Modified: 2014-08-17 18:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 809873 (view as bug list)
Environment:
Last Closed: 2012-05-15 18:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check_matches_fail (172.49 KB, image/png)
2012-03-21 12:06 EDT, dgao
no flags Details
checkmatch_english (222.62 KB, image/png)
2012-04-04 02:20 EDT, Rehana
no flags Details
checkmatch_french (216.90 KB, image/png)
2012-04-04 02:20 EDT, Rehana
no flags Details

  None (edit)
Description dgao 2012-03-21 12:06:34 EDT
Created attachment 571757 [details]
check_matches_fail

[root@dell-pem600-01 nodes]# rpm -qa | grep "conductor"
aeolus-conductor-doc-0.8.0-43.el6.noarch
aeolus-conductor-0.8.0-43.el6.noarch
aeolus-conductor-daemons-0.8.0-43.el6.noarch

Check Matches button in the Edit page doesn't actually produce any check results, instead it saves the changes and take us back to the main hardware profile page.
Comment 2 wes hayutin 2012-03-21 12:33:05 EDT
just want to pose this as a question to devel.. to see if we want to try and fix this..
Comment 3 Matt Wagner 2012-03-27 10:35:12 EDT
This appears to work properly when creating a *new* hardware profile, but not on edit. I'm investigating the reason now.
Comment 5 Matt Wagner 2012-03-27 14:34:40 EDT
On master: 0f958b4080f19d48d9aac829b81a9a1f85ff1601

On 1.0-product: c79a5cd82cacdb7567f7ab5d710d905cb8f02028
Comment 7 Rehana 2012-04-04 02:19:42 EDT
Check match on 'English' language is working (PFA:checkmatch_english.png) however i observed that the same functionality on 'French' language is still not working, it doesn't show any matching profile on edit page.(it works for new hwp)
(PFA; checkmathch_french.png)

observed on;

rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-0.8.7-1.el6.noarch
aeolus-conductor-doc-0.8.7-1.el6.noarch
aeolus-conductor-daemons-0.8.7-1.el6.noarch
aeolus-configure-2.5.2-1.el6.noarch
aeolus-all-0.8.7-1.el6.noarch
rubygem-aeolus-cli-0.3.1-1.el6.noarch
Comment 8 Rehana 2012-04-04 02:20:22 EDT
Created attachment 575040 [details]
checkmatch_english
Comment 9 Rehana 2012-04-04 02:20:55 EDT
Created attachment 575041 [details]
checkmatch_french
Comment 10 wes hayutin 2012-04-04 10:32:28 EDT
fixed in english, the bug is found only in a translated versions.
Translated versions of CE are not considered blockers in 1.0.0

This will be fixed in 1.0.z
Comment 12 errata-xmlrpc 2012-05-15 18:58:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html

Note You need to log in before you can comment on or make changes to this bug.