Bug 805594 - Multiple "subscribe" buttons that do different things
Multiple "subscribe" buttons that do different things
Status: CLOSED DUPLICATE of bug 803374
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Alex Wood
J.C. Molet
:
Depends On:
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-03-21 12:27 EDT by J.C. Molet
Modified: 2012-04-18 23:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-30 13:20:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2012-03-21 12:27:36 EDT
Description of problem:
In subscription-manager-gui, there are multiple buttons named "Subscribe":

- The one in "My Installed Software" which initiates the SLA based auto-subscribe.

- The one in "All Available Subscriptions" used to subscribe to subscriptions

This causes issues with people using the accessibility API as both buttons are direct children of the 'Subscription Manager' window/object and therefore indistinguishable from each other.

This also breaks all automation having to do with subscribing and unsubscribing from individual subscriptions (id est: most tests).

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.99.10-1.git.85.057ca98.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. fire up subscription-manager-gui
2. Navigate to the 'All Available Subscriptions' tab, search and select an item
3. use your favorite at-spi tool to click on the 'Subscribe' button:
 python -c "import ldtp; ldtp.click('Subscription Manager','Subscribe')"
  
Actual results:
The subscribe button under 'My Installed Software' has the same at-spi name as the one under 'All Available Subscriptions', and it gets clicked on, and my system attempts to autosubscribe.

Expected results:
The subscribe button under 'My Installed Software' has a different name and clicking subscribe subscribes me to a subscription.

Additional info:
This would be a great opportunity to change the name of the SLA subscribe to "Autosubscribe" or similar.
Comment 1 Alex Wood 2012-03-23 09:34:02 EDT
Committed 167478ad9e4b5d4ffae9545abd5ac20dbe3cb705

Available subscription-manager-0.99.12+
Comment 4 John Sefler 2012-03-28 13:52:41 EDT
"Auto-subscribe" is probably the best choice.

Reference: http://english.stackexchange.com/questions/7657/use-of-hypens-with-auto-autopopulate-auto-populate-or-auto-populate
Comment 5 Alex Wood 2012-03-30 13:20:37 EDT

*** This bug has been marked as a duplicate of bug 803374 ***

Note You need to log in before you can comment on or make changes to this bug.