Bug 805641 - Memory leak happens when resizing resolution in guest
Memory leak happens when resizing resolution in guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 13:51 EDT by Marian Krcmarik
Modified: 2012-06-20 08:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Resizing remote display resolution. Consequence: Large memory leak. Fix: Remove the memory leak when resizing guest resolution. Result: Remote display can be resized without memory leak.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-03-21 13:51:49 EDT
Created attachment 571798 [details]
/var/log/messages

Description of problem:
Memory leaks happen when resizing resolution on guest or scaling remote-viewer client. When running a hundreds of quick resolutions changes The resident memory of client process seems to be stable but cache memory is all eaten up to the top of available memory and then whole swap is eaten as well which results in crash of client system (possible see the attached output from messages).

Version-Release number of selected component (if applicable):
Client is RHEL6.3, Guest fedora or Windows7
spice-gtk-0.11-1.el6.x86_64
spice-glib-0.11-1.el6.x86_64
spice-gtk-tools-0.11-1.el6.x86_64
spice-gtk-python-0.11-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect with remote-viewer to a guest.
2. If the guest is Linux run something like:
for ((i=0;$i<2000;i++)); do echo ${i}; if [ "x$((i%3))" == "x0" ]; then MODE="1280x800"; elif [ "x$((i%3))" == "x1" ]; then MODE="1440x900"; else MODE="1680x1050"; fi ; xrandr --output default --mode "${MODE}" 2> /dev/null; sleep 0.3333333; done
OR
If guest is Windows use tool i.e nircmd utility to change resolution in a loop (www.nirsoft.net/utils/nircmd.html)
  
Actual results:
cache memory and swap starts to dramatically get high which results to remote-viewer or system crash

Expected results:
Stable memory results

Additional info:
Comment 2 Marc-Andre Lureau 2012-03-22 09:27:06 EDT
Fixed upstream

commit 6db275a422013a34247b805923f88b23db850ea1
Author: Marc-André Lureau <marcandre.lureau@redhat.com>
Date:   Wed Mar 21 19:18:38 2012 +0100

    Always release shm of primary surfaces
    
    Always remove shared memory segment of primary surfaces when
    destroying its canvas.
Comment 8 Marc-Andre Lureau 2012-04-20 09:22:40 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 Marc-Andre Lureau 2012-04-20 09:42:38 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,11 @@
-No documentation needed.+Cause:
+Resizing remote display resolution.
+
+Consequence:
+Large memory leak.
+
+Fix:
+Remove the memory leak when resizing guest resolution.
+
+Result:
+Remote display can be resized without memory leak.
Comment 11 errata-xmlrpc 2012-06-20 08:19:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.