Bug 805668 - mount.glusterfs won't auto mount gluster filesystems from /etc/fstab on boot even with the auto mount option
mount.glusterfs won't auto mount gluster filesystems from /etc/fstab on boot ...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 14:56 EDT by csb sysadmin
Modified: 2013-12-18 19:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 04:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 101223 None None None Never

  None (edit)
Description csb sysadmin 2012-03-21 14:56:08 EDT
Description of problem:

mount.glusterfs won't automatically mount gluster filesystems from /etc/fstab on boot even when the fstab line looks like this :

gluster1:/pirdist       /pirdist                glusterfs transport=tcp,auto        0 0

Version-Release number of selected component (if applicable):

3.2.5

How reproducible:

Always


Steps to Reproduce:
1. Create a line in /etc/fstab for the gluster filesystem and mount point with or without the auto mount option.
2. Reboot system
3. Gluster filesystems are not mounted after boot.
  
Actual results:

Gluster filesystems from /etc/fstab are not mounted after boot

Expected results:

Gluster filesystems from /etc/fstab should be automatically mounted after boot by default, and especially so if the "auto" option exists and is used if you guys decide to not make it the default behavior.

Additional info:

Currently have "mount /pirdist" in /etc/rc.local and that seems to be a reasonable workaround.
Comment 1 Amar Tumballi 2012-05-02 12:28:58 EDT
this needs a '_netdev' option too in the line. Please let us know if providing '_netdev' in /etc/fstab helps or not.
Comment 5 Niels de Vos 2012-07-10 02:32:05 EDT
This only affects glusterfs-3.2.x (RHSSA-3.2). This issue is resolved in glusterfs-3.3 (in RHS-2.0).
Comment 6 Amar Tumballi 2012-10-29 04:52:04 EDT
we are not working on fixing any issues on RHSSA-3.2. Will close the bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.