Bug 805700 - [abrt] firewall-applet-0.2.4-1.fc17: Gtk.py:1381:popup:AttributeError: 'Menu' object has no attribute 'popup_for_device'
[abrt] firewall-applet-0.2.4-1.fc17: Gtk.py:1381:popup:AttributeError: 'Menu'...
Status: CLOSED DUPLICATE of bug 802107
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:922ad7d1efe95894bc32d4520b9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 16:44 EDT by Amir Hedayaty
Modified: 2012-03-21 16:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 16:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amir Hedayaty 2012-03-21 16:44:45 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /bin/firewall-applet
executable:     /bin/firewall-applet
kernel:         3.3.0-1.fc17.x86_64
reason:         Gtk.py:1381:popup:AttributeError: 'Menu' object has no attribute 'popup_for_device'
time:           Wed 21 Mar 2012 01:43:53 PM PDT
uid:            1000
username:       amir

backtrace:
:Gtk.py:1381:popup:AttributeError: 'Menu' object has no attribute 'popup_for_device'
:
:Traceback (most recent call last):
:  File "/bin/firewall-applet", line 267, in right_menu_cb
:    self.statusicon, button, time)
:  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py", line 1381, in popup
:    self.popup_for_device(None, parent_menu_shell, parent_menu_item, func, data, button, activate_time)
:AttributeError: 'Menu' object has no attribute 'popup_for_device'
:
:Local variables in innermost frame:
:parent_menu_item: None
:activate_time: 2542626L
:parent_menu_shell: None
:button: 3L
:func: <function position_function at 0x1e1c938>
:data: <StatusIcon object at 0x1e1d370 (GtkStatusIcon at 0x1e919e0)>
:self: <Menu object at 0x1e1d730 (GtkMenu at 0x1bb2360)>
Comment 1 Thomas Woerner 2012-03-21 16:57:51 EDT

*** This bug has been marked as a duplicate of bug 802107 ***

Note You need to log in before you can comment on or make changes to this bug.