Bug 805706 - Need to add a scrollbar for Organization selector
Need to add a scrollbar for Organization selector
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-21 16:56 EDT by Og Maciel
Modified: 2013-08-16 14:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 16:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
All of the available organizations under the Organizations tab (90.39 KB, image/png)
2012-03-21 16:57 EDT, Og Maciel
no flags Details
Dropdown showing only a few organizations to select from (95.25 KB, image/png)
2012-03-21 16:57 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-03-21 16:56:28 EDT
Description of problem:

If you have "too many" organizations created, the organization selector/dropdown won't display all of them. See attached screenshots for a list of all available Organizations as shown under the Organizations tab and what shows up in the dropdown widget.

WORKAROUND: Type the name of the Org and the available list will shrink down to your criteria.

Version-Release number of selected component (if applicable):

* candlepin-0.5.26-1.el6.noarch
* candlepin-tomcat6-0.5.26-1.el6.noarch
* katello-0.1.305-1.el6.noarch
* katello-all-0.1.305-1.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.4-1.el6.noarch
* katello-cli-0.1.105-1.el6.noarch
* katello-cli-common-0.1.105-1.el6.noarch
* katello-common-0.1.305-1.el6.noarch
* katello-configure-0.1.106-1.el6.noarch
* katello-glue-candlepin-0.1.305-1.el6.noarch
* katello-glue-foreman-0.1.305-1.el6.noarch
* katello-glue-pulp-0.1.305-1.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.9-1.el6.noarch
* pulp-1.0.0-5.el6.noarch
* pulp-admin-1.0.0-5.el6.noarch
* pulp-client-lib-1.0.0-5.el6.noarch
* pulp-common-1.0.0-5.el6.noarch
* pulp-selinux-server-1.0.0-5.el6.noarch

How reproducible:


Steps to Reproduce:
1. Create 8 different organizations
2. Attempt to select the first organization you created from the upper Org selector dropdown widget
3.
  
Actual results:

You can only see a small fraction of the available orgs.

Expected results:

Should be able to see/select them all.

Additional info:
Comment 1 Og Maciel 2012-03-21 16:57:11 EDT
Created attachment 571848 [details]
All of the available organizations under the Organizations tab

All of the available organizations under the Organizations tab
Comment 2 Og Maciel 2012-03-21 16:57:52 EDT
Created attachment 571849 [details]
Dropdown showing only a few organizations to select from

Dropdown showing only a few organizations to select from
Comment 3 Tom McKay 2012-10-24 16:01:05 EDT
Fixed some time ago
Comment 4 Mike McCune 2013-08-16 14:00:48 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.