Bug 80571 - Created boot Floppy disk incorrect
Summary: Created boot Floppy disk incorrect
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-28 02:55 UTC by Hans Oeste
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 18:53:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans Oeste 2002-12-28 02:55:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I've got XP Pro on /dev/hda and already had to repair it once because of grub,
so I decieded to to use a boot floppy to start this installaion.  Only the boot
disk loads vmlinuz fist and then initrd which is backwards so the root
installation on /dev/hdb2 never runs/loads.

I've tried editing the syslinux.cfg file on the boot disk to no avail.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Hans Oeste 2002-12-28 19:28:42 UTC
Did some more investigation by downlaoding the latest version and version 1.65
of syslinux and creating bootdisk for each version.  It didn't work.  So
syslinux must handle initrd transparently in version 2.00.  The last line in the
boot up process is:

RAMDISK: Compressed image found at block 0

and there she hangs.  So it must be the image.  I think....  I've tried giving
it the root param on the command line and it didn't help.  At this point I'm at
a loss.  This behavior is with both versions of syslinux.

Comment 2 Bill Nottingham 2003-01-01 04:43:31 UTC
Is your floppy full?

Comment 3 Hans Oeste 2003-01-02 02:21:54 UTC
Not quite, 512 bytes free.

Comment 4 Hans Oeste 2003-01-11 23:11:06 UTC
Done some more work on this little thing.

In a dos box in XP with the flopy disk in drive a: and the CD1 mounted I went

rdev a:\vmlinuz  3 67

This was done from the dosutils directory and used the parameters for that 
partion since my root partion for Linux is /dev/hdb3.

On booting it worked until the point where it is trying to mount the root 
filesystem.  It becomes apparent that it's trying to use resierfs instead of 
ext3 for the filesystem driver.

I thought that the Redhat default filesystem was to format as ext3.  So why 
does the floppy have the resierfs filesystem driver compiled in?  Could someone 
at RedHat create a bootdisk that has the ext3 filesystem driver compiled in?

Comment 5 Matt Wilson 2003-02-11 06:09:26 UTC
don't use rdev on your boot disk.

lots of this changed lately - try everything again in the next beta



Note You need to log in before you can comment on or make changes to this bug.