Bug 805757 - info test missing requires for sos (sosreport)
info test missing requires for sos (sosreport)
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.5
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Greg Nichols
Guangze Bai
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-03-21 23:12 EDT by Guangze Bai
Modified: 2015-02-08 16:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An enhancement has been made in v7 1.5 that pakcage `sos` now is a installing dependency of package `v7`
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guangze Bai 2012-03-21 23:12:33 EDT
Description of problem:

Running info on system without sos package, it fails like:

  Subtest: System Report - generate system report
  sh: line 2: sosreport: command not found
  sh: line 2: sosreport: command not found

but actually in plan phase, it only prompts:

  info requires kabi-whitelists, policycoreutils



Version-Release number of selected component (if applicable):
v7-1.4-38 and v7-1.5-9


Expected results:
make sure all rpms installed associated with info test in advance

Additional info:
Comment 1 Greg Nichols 2012-03-22 12:59:25 EDT
It looks like "sos" should be added to the required rpms for v7, unless there's a different rpm under RHEL5 vs. 6 or 7.
Comment 2 Rob Landry 2012-03-22 13:17:49 EDT
There are .el5 sysreport packages, the predecessor to sos, but the info test always calls sosreport except on RHEL4.  Adding the sos %requires makes sense to me.
Comment 8 Caspar Zhang 2012-06-04 03:58:50 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An enhancement has been made in v7 1.5 that pakcage `sos` now is a installing dependency of package `v7`
Comment 10 errata-xmlrpc 2012-06-05 17:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.