Bug 805788 - Option -smp maxcpus does not completely work
Option -smp maxcpus does not completely work
Status: CLOSED DUPLICATE of bug 807512
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 02:59 EDT by juzhang
Modified: 2012-04-02 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 09:10:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description juzhang 2012-03-22 02:59:03 EDT
Description of problem:
Boot guest with -cpu 4,maxcpus=8, then hot add vcpu. from monitor, we can see that we can hot add more than 8 vcpus. in guest, guest can recognize maxcpus.from guest of view,this is ok,however,from monitor view,it's not very good.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.257.el6.x86_64
seabios-0.6.1.2-13.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot guest -cpu 4,maxcpus=8
2.Hot add vcpu
3.(qemu) info cpus 
* CPU #0: pc=0xffffffff810377cb (halted) thread_id=10742 
  CPU #1: pc=0xffffffff810377cb (halted) thread_id=10743 
  CPU #2: pc=0xffffffff810377cb (halted) thread_id=10744 
  CPU #3: pc=0xffffffff810377cb (halted) thread_id=10745 
  CPU #4: pc=0xffffffff810377cb (halted) thread_id=10844 
  CPU #5: pc=0xffffffff810377cb (halted) thread_id=10845 
  CPU #6: pc=0xffffffff810377cb (halted) thread_id=11219 
  CPU #7: pc=0xffffffff810377cb (halted) thread_id=11221 
  CPU #8: pc=0x00000000fffffff0 thread_id=11223 
  CPU #9: pc=0x00000000fffffff0 thread_id=11225 
  CPU #10: pc=0x00000000fffffff0 thread_id=11426 
  CPU #11: pc=0x00000000fffffff0 thread_id=11427
  
Actual results:
After step3,as you can see,more than 8 vcpu

Expected results:
Should give a friendly message that tell user can not hot add vcpu more than maxcpus number.

Additional info:
In guest,guest can recognize maxcpus number at most, from guest point,it's ok.
Comment 1 Igor Mammedov 2012-04-02 09:10:16 EDT
to fix it we need sanity check for maxcpus and bug 807512 are about the same. So I'll dup it to bug 807512

*** This bug has been marked as a duplicate of bug 807512 ***

Note You need to log in before you can comment on or make changes to this bug.